Simply reset usb hub after boot

I'm not sure what is causing this but upon boot, the current connected device in the usb3 port is never detected. I get nothing in dmesg.
ie: there is nothing in lsusb or dmesg about a device connected to the usb.
a simple usb3 flash drive will be detected on boot just fine, but the device I need (cellular modem) isnt.
I'm not sure if its a power issue or what, but a simple unplug and replug in will fix it.

I dont really care about any of that though, what I want to do is disable the usb hub and re-enable it if the device isnt detected.
there used to be a package usbreset but it is no longer in the package manager for some reason.
Was it replaced?
If not that, I tried googling around and it seems people suggest setting suspend to /sys/bus/usb/devices/usb4/power/level but there is no power directory in usb4 (the hub for the port)

What else can I do to reset this usb hub?

Use usbutils instead.;a=commit;h=6cda95431984312d15032f6466b3b7238936185b

I see. I tried this but unfortunately it gives no such device found.
usbreset 004/001
usbreset 1d6b:0003
usbreset /dev/bus/usb/004/001
usbreset /sys/bus/usb/devices/usb4
usbreset /sys/bus/usb/devices/4-1

all give no such device found despite all being correct for the hub.

I never heard about a hub being stuck. What you describe sounds more like a missing xhci driver to me. Compare your output with this (from a Linksys EA7300 v2):

usb_common              2704  3 xhci_plat_hcd,xhci_hcd,usbcore
usbcore               141312  4 xhci_plat_hcd,xhci_pci,xhci_mtk,xhci_hcd
xhci_hcd              115616  3 xhci_plat_hcd,xhci_pci,xhci_mtk
xhci_mtk                4928  0 
xhci_pci                3744  0 
xhci_plat_hcd           5856  0