Simple way to disable IPv6 on LAN side?


I have read posts about disabling IPv6 on OpenWRT standard builds, but cant seem to find an answer to my question. If it's out there, then appologies for any repetition.

I'm running the latest standard build for a BT Home Hub 5 (22.03.4) and my ISP is Now Broadband, who support IPv6. The issue I have is one of my LAN clients (wireless) doesnt like IPv6 (a Sony Smart TV) which causes it to repeatedly disconnect and reconnect to the wireless network, so the straight forward solution is to disable it on the LAN - although the other clients dont have an issue with IPv6, IPv4 only on the LAN is fine for my needs. The Sony TV's OS doesnt have any option to dissable it's IPv6 functionality so this isnt a possibility.

When I read other posts on disabling IPv6, it all seems rather complicated so I tried what appeared to be a simple solution (to me anyway) of disabling the RA-Service and DHCPIPv6-service on the LAN interface using the options in LuCI under network/interfaces/lan/DHCP Server/IPv6. This appears to have done the trick, as none of my LAN clients now have an allocated IPv6 address, nor any IPv6 DNS server addresses, and the errant Smart TV no longer plays up.

My question is :- have I done something stupid by disabling these services but leaving all other IPv6 settings the same, and unwittingly caused issues that arent apparent to me but could be adversly affect network performance ?

I dont do anything fancy on my home network so everything appears to be fine.


Why not leave IPv6 enabled and add a new Wireless ssid with IPv6 disabled for your TV.

You should not disable IPv6 since it is very efficient than IPv4.

1 Like

Sounds like it should be ok. Just a note: you probably still have IPv6 going on with LLAs (link local addresses, fe80::/10), but since they (almost) never change, there's no expiration and they shouldn't cause any bouncing.

I'm curious as to the root cause of the Sony's problem; it sort of sounds like DHCP with a too-short lease interval. I wonder if it's expecting just DHCPv6 or just RA prefix delegation or what? If you do any experiments (say, turn off just RA/SLAAC, or assign the TV a lease reservation, or ???), please report back as I'd be interested in the results.

1 Like

Hi efahl and thanks for replying.

I had noticed the LLAs were still present but as you say, they arent causing any problems so I will probably leave well alone. Just in case, what setting do I need to change to disable LLAs ?

The Sony TV issue is well documented - if you Google "Sony Bravia TV keeps disconnecting and reconnecting form the internet" you'll see a lot of people complaining about it and the only thing that stops it is disabling ipv6. Sony have never publicly acknowledged the issue or issued a fix so the root cause remains a mystery, although my TV is now over 5 years old so newer models may not have the issue any more.

Thanks again.

1 Like

Hi openwrtforever and thanks for your response.

I've read in other threads about creating a separate ssid with ipv6 disabled but I can't see how this can be done. When I use LuCI to create a new ssid, at no point are there any settings regarding ip protocols. The ipv6 settings I can find are under the LAN configuration so does that mean I need to create a separate LAN as well as another ssid to implement your suggestion?

try I want to disable IPV6 from LAN Interface using Luci

for DSA-based devices:
network > interfaces > devices > br-lan > configure > general device options > enable ipv6

1 Like

Go to Network > Wireless > Add Button
Add your SSID Name and Password, in the Network Dropdown type in Custom field a new network name "IPv4only" something like that and save.

Then go to Network > Interfaces, edit IPv4only Interface and add a new IPv4 range like and go to DHCP server, ADD and setup a new DHCP server and go to IPv6 settings and disable all server mode.

1 Like

Can't you configure a static IP via the TV's settings?

Thanks to all who replied.

I have enough info to achieve what I wanted, my home network is working and the annoying messages from my TV have stopped, so I'll leave it there before I exceed my capabilities !

Thanks again !

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.