Simple WAN/LAN configuration not working

I have an ASUS RT-AC51U. I had the setup for my network working before, but installed too many packages for the little memory this device had and bricked it when trying to remove some. So I started over with the current openwrt, but can't get the old configuration working again.

It has a fixed IP in the WAN and the usual for the LAN.
I have access to LuCI, but the router appears offline. The network admin said that he can see the MAC address of the router, but also the one from the LAN port and other MAC addresses from connected devices, that's not good, it should appear as one device towards the WAN. What could be wrong?


Did you perform a factory reset to restore openwrt to default settings using LuCI or with the Reset button?

Then edit your WAN interface settings, and check LAN devices are working before making any further changes.


Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
1 Like

eth0.1 on the wan doesn't look right. This is usually the lan interface.

Which one should it be? I also tried eth0 but that doesn't work either.

I used the reset function in LuCI, entered the same data again (Now there is a netmask field, which was not present before..) It works now. eth0.1 is correct btw.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.