Simple switch configuration on ipq807x QCA-SSDK switch driver

Hi.

I want to achieve a really simple task on a ipq8072 router (QNAP) that uses QCA-SSDK driver for its switch.
It doesn't use the older swconfig driver nor the newer DSA driver.
I want one of the LAN ports to be connected to the WAN port of another router.
So the second router could simply get its own WAN IP via DHCP as the first router and avoid double NAT. I need this setup for testing.
Simply said I want the LAN port to act as a simple switch (no VLANs) and just connects the ISP network to the WAN port of the second router as in the case we have a real hardware device (switch).
I used to do it with older swconfig driver using VLANs and it worked. Just used to bridge the LAN port (removed from the br-lan) with WAN port.
Now I cannot achieve this with my current config. The second router doesn't get IP addresses (IPv4 nor IPv6) via DHCP.

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdf1:a5:b5::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports '10g-2'
	list ports 'lan2'
	list ports 'lan3'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '64'
	list ip6class 'wan6'

config interface 'wan'
	option device 'lan1'
	option proto 'dhcp'
	option hostname '*'

config interface 'wan6'
	option device 'lan1'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'
	option norelease '1'

config device
	option type 'bridge'
	option name 'br-vlan'
	option bridge_empty '1'
	list ports 'lan4'

config interface 'guest'
	option proto 'static'
	option device 'br-vlan'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option delegate '0'

config interface 'switch'
	option proto 'none'
	option device '10g-1'

I've tried this config too. No result.

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdf1:a5:b5::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports '10g-2'
	list ports 'lan2'
	list ports 'lan3'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '64'
	list ip6class 'wan6'

config interface 'wan'
	option device 'lan1'
	option proto 'dhcp'
	option hostname '*'

config interface 'wan6'
	option device 'lan1'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'
	option norelease '1'

config device
	option type 'bridge'
	option name 'br-vlan'
	option bridge_empty '1'
	list ports 'lan4'

config interface 'guest'
	option proto 'static'
	option device 'br-vlan'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option delegate '0'

config interface 'switch'
	option proto 'none'
	option device 'switch'

config device
	option type 'bridge'
	option name 'switch'
	list ports '10g-1'

Thanks.

On swconfig models, UCI parses the config file then runs the userspace binary swconfig as the backend which loads configurations into the switch hardware.

Clearly that is not going to work with a system other than swconfig. Whatever userspace configurator is involved with QCA will need to be called directly, as there is no support for it in the UCI system of scripts.