SIM7600G-H not connecting to internet


I'm using SIM7600G-H Module did the following qmi setup

and as you can see in the image it says Unknown error (NETWORK_REGISTRATION_FAILED)

I'm not sure what is happening

Commands i ran

uqmi -d /dev/cdc-wdm0 --start-network internet --autoconnect

uqmi -d /dev/cdc-wdm0 --get-data-status

uqmi -d /dev/cdc-wdm0 --get-serving-system
        "registration": "registered",
        "plmn_mcc": 404,
        "plmn_mnc": 45,
        "plmn_description": "airtel",
        "roaming": true

uqmi -d /dev/cdc-wdm0 --get-signal-info
        "type": "lte",
        "rssi": -54,
        "rsrq": -12,
        "rsrp": -84,
        "snr": 1.000000

Additional information:

Hardware: RPi Zero W

and you're sure the APN name really is hologram ?

1 Like

Hi @frollic,

Yes it is hologram

Why are you using non-standard QMI driver?
Are you sure that your carrier supports IPv4/IPv6 ?

what do you mean by non-standard QMI driver?

I referred to this to configure

this is how it looks as rdins host so i believe it supports IPv4 and v6

usb0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN qlen 1000
    link/ether ba:6b:db:dc:52:21 brd ff:ff:ff:ff:ff:ff
    inet brd scope global usb0
       valid_lft forever preferred_lft forever
    inet6 fe80::b86b:dbff:fedc:5221/64 scope link
       valid_lft forever preferred_lft forever

I was confused by the device name shown on the screenshot - qmi-SIM7600, as typically we have wwan0 there.
IPv4/v6 question is related to your carrier only.

Assuming you're still "connected" check this:
uqmi -d /dev/cdc-wdm0 --get-current-settings

There is only an IPv4 address applied; IPv6 is not configured beyond the automatic link-local that every interface has.

Also, QMI is not RNDIS.

hi @AndrewZ,

yes it shows connected

Hi @mk24,

I know QMI is not RNDIS i put it here because i was not sure about IPv4/v6.

If it is "connected" please provide the uqmi output as requested and clarify about the driver used.

i dropped plan of configuring QMI