Sierra Wireless MC7455 pcie on GL-MIFI Router

Hi. I am new to all this and hope someone can help.
I have a GL-MIFI router running OpenWrt 18.06.1.
I have installed a Sierra Wireless MC7455 and the router does not recognize it.
Any ideas?

Thanks in advance.

Well, if the driver of the card isn't included then you will have to add it.

1 Like

Well, looking st your device I imagine you must be using a USB adapter.

See if this help.

Do you have USB support?

1 Like

Hi. Thanks for the quick reply.
I have limited knowledge with this.
I have looked here. https://source.sierrawireless.com/resources/#tags=MC7455
There are various drivers etc. I have no idea what one to use or how to install it.
Any help will be appreciated.
If it is not possible then I can return the card to the supplier.
Thanks.

I realized it must be connected via USB after I sent the first message. so please put aside what I said about the driver for now.

Search the forum for MC7455. It looks like some people are already using it. Though I imagine you would need to make sure that you have USB support.

You might find this interesting reading


Also as a temporary work around the USB 3.0 issue to see if it's the problem, you could just use a USB 2.0 extension cable between the card and the router.

You could go through this https://openwrt.org/docs/guide-user/storage/usb-installing to check USB support.

Hi.
Thanks for the advice. Tried taping the pins. Still nothing.
Under interfaces I have an option "MODEM_1_1_2 (3g modem)" I click the restart button but all that comes up is "Network device is not present"
Thanks again.

Follow the USB guide in the kink above to make sure you have support for USB 2.0 at least, or USB 3.0 if your router supports that.

You could use a memory stick to make sure the USB is configured.

1 Like

See https://openwrt.org/docs/guide-user/network/wan/wwan/ltedongle

The MC7455 can be configured for either QMI or MBIM, so you might want to install both drivers. It doesn't do mode switching, so you can drop usb-modeswitch and related instructions.

The first task is to verify that the connection is OK, including power to the slot etc. Follow the instructions and report back what you see.

Hi.
Thanks for all the advice.
I finally got things going.
They e-mailed me an updated firmware which now includes support for this modem.
The only thing I had to do was change was the apn. The old modem needed "wap.cingular" to connect. The MC7455 needed "broadband" to connect.
Many thanks to everyone for being so quick to help.
Hope this info may help others.

1 Like

So that someone that finds this later knows what to look for, which version number of the GL.iNet firmware are you now running?

Here is the firmware they sent me. It works but the only issue is that the 4G led doesn't light up. You can set the led up in the advanced setting but it doesn't save after reboot. Use at your own risk.
https://mega.nz/#!vsE3AKpS!S5PtjChwKdJOwPs3sCzzlU8Bs0ebMXbbsIUVQioqj8M

There is also an experimental firmware on the site. I have not yet tried this yet.
https://dl.gl-inet.com/firmware/mifi/testing/

hello,

Do you know how the MC7455 performs on the MIFI?
What are the upload and download rates going to be?

Thanks

Hi.

Upload averages around 12-13 Mbps, Download around 25-27.
I have a mofi 4500 router with the same card. Speeds are the same on that as well. Must be the maximum speed of the tower I am on.

UPDATE.

Only firmware openwrt-mifi-3.022-0428 works with the MC7455. (see mega link in my earlier post).
The openwrt-mifi-3.023-0513 from the website reports the MC7455 an a MC7430 and does not work.
To connect to AT&T you need to do the following.
Click on at command and type:
AT!IMPREF="ATT"

Go back to internet and run Auto setup.
When it tries to connect and an imei number shows up click abort
Change apn to broadband.
Delete user name
Click apply.

Many thanks to the amazing tech support from GL.iNet for working with me on this.
Hopefully all issues will be ironed out.

I will update when any changes.

Please note that the 3g/4g led will not work but you will be connected (see earlier post)

2 Likes

Hi,

I placed the MIFI test firmware here, which supports MC7455.

I places an EM7656 into the Mifi with GoldenOrb FW, it works but not too stable. Apparently the Sierra draws to much power so that tge device restarts if the battery is too weak.