Sierra Wireless MC7455, only /dev/ttyUSB0

Hi@all,

I build my own router out of a Mini PC resp. what is also known as "Firewall Appliance". I got this device from Amazon. These device are sold under different brands, but inside are typically boards from BKHD. My device got a BKHD-12646NP-12-6L, which has a SIM card slot and an mPCIe slot.

I put a Sierra Wireless MC7455 LTE modem into the slot, but I cannot get it up and running. I already read in this thread that the modem needs to be configured. But they say that the modem should create three devices, /dev/ttyUSB0, /dev/ttyUSB1, and /dev/ttyUSB2. I only get one device, which is ttyUSB0. I also don't see any /dev/cdc-* or /dev/sdc-* device.

lsusb:

Bus 002 Device 001: ID 1d6b:0003 Linux 5.15.150 xhci-hcd xHCI Host Controller
Bus 001 Device 002: ID 1199:9070 Sierra Wireless, Incorporated MC7455-CP
Bus 001 Device 001: ID 1d6b:0002 Linux 5.15.150 xhci-hcd xHCI Host Controller`

lsusb -t:

/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 10000M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/12p, 480M
    |__ Port 8: Dev 2, If 0, Class=, Driver=qcserial, 480M

I tried to connect to /dev/ttyUSB0 using socat to sent AT commands, but this doesn't work. Every command just returns 0 (zero).

I don't know what to do. How can I get the modem to work? Please help!

Please see EM7455B connection issues - #8 by AndrewZ

Sorry, but I have no idea what you are talking about in this post.

Part 1 (unrelated to OpenWrt):

  • make the modem GENERIC (not Dell)
    • -> I don't understand a word
  • upgrade its firmware to the latest
    • -> Good point, I need to check how to do that, but I'm afraid AT commands are required, isn't it?
  • switch it to MBIM + comm ports composition
    • -> That's my problem, how without working AT commands?
  • disable FCC Auth
    • -> I don't understand a word

Part 2:

Can you please explain in better detail what you mean?

First the modem must be brought into working condition, this has nothing to do with OpenWrt.
I suggest to ask a question in Sierra's forum.

EM7455, can't get it to work on 21.02.3 - #33 by frollic and onward might help, plus
https://github.com/danielewood/sierra-wireless-modems

In this case the modem is half dead (probably stuck in download mode).

Yes, it's stuck in the bootloader. Running a firmware upgrade tool like qmi-firmware-update might fix that, unless the modem is completely broken.

Right, running an updater may or may not help.
There is also a possibility that the modem cannot boot because of the host system, for example, due to some pin state on mPCIe connector, it would be good to test it in a known good USB adapter.

That's right. Covering the usb3/pcie pins is probably a better place to start unless the OP has an adapter and can run the at!usbspeed command. Ref

1 Like

... and RESET (pin 22)

Thx for the tipps. I played around a little bit and tried different tools/scripts, but nothing could detect the modem. I tried it inside the Mini PC as well as using a USB adapter (which is confirmed working, because it works with another different modem), but it does not work. I'm afraid the modem is broken.

I'm not very motivated to tinker with covered pins, but if I cannot return the modem, maybe I'll try it out.

I'm afraid there is no point if the modem doesn't work in a USB adapter. Taping pins will only help in a slot with PCIe or other unwanted signals

Did you try the frmware upgrade? Something like

qmi-firmware-update  --verbose --tty=/dev/ttyUSB0 --update-download SWI9X30C_02.38.00.00.cwe SWI9X30C_02.38.00.00_GENERIC_002.082_000.nvu

or whatever firmware version you have/want. The idea is to try to bring the modem out of the current state, and the upgrade tools is good at that since it speaks several of the weird qualcomm serial protocols. There isn't necessarily anything wrong with the modem. It could just be waiting for a debug tool to attach. I believe these modems will enter a ramdump state on some errors.