Sierra Wireless MC7430 mPCIE LTE modem + Unielec U7621 in LEDE

What are the general requirements to use a Sierra Wireless MC7430/MC7455 in LEDE? I have been researching, but have a few miscellaneous questions.

What I know so far is the modem can be in either MBIM or QMI mode, and I need to be using kernel 4.5 or above (I am using 4.9) to use QMI mode features. There is also a Sierra Gobi driver set that I could use. Is that as simple as compiling it, then loading it into a running LEDE installation using modprobe?

To control and use the modem I need several software packages, but could someone post a definitive list of them here for either QMI or MBIM mode? I see several online, but I have yet to have success with any of those. They generally suggest using uqmi or umbim.

ModemManager: This looks very nice. If I want to use this, will I need to compile my own LEDE image with it added via feeds? Any plans in the near future to make ModemManager a regular package?

Take a look at this patch

Read through all versions

Thanks, now I know how to bring the interface up, but my current problem is I do not have the /dev/cdc-wdm0 interface. I put the modem into QMI mode, but have also tried with MBIM mode. How can I get the right kernel modules onto the system to use the modem?

It may be worth mentioning that I am trying to use this modem in the mPCIE slot and the MC7430 is running the generic firmware.

Install kmod-usb-net-qmi-wwan and kmod-usb-net-cdc-mbim

Thank you, bmork, those were already installed and loaded I'm afraid. I get absolutely nothing in dmesg when I plug in the modem. I have also looked under /sys/class/net for an interface, but I am not really sure where else to look.

I have tested the same mPCIE slot with a Huawei me906s, and all of its' interfaces showed up fine. Also, the Sierra modem works under Ubuntu and Windows, and I am positive that it is in QMI mode (at!usbcomp=1,1,10D).

I'm using the newly supported Unielec U7621 with the u7621-06-256M-16M-squashfs-sysupgrade.bin image as a base, but I have also compiled one with Modem Manager. I have the MC7430 plugged into the LTE module slot on the left in the image below.

The power supply is supposed to supply 12V and 1 amp of power (my next test will be to put a multimeter on the power supply). I wonder if the modem requires more power? In an attempt to rule out the power supply, I have removed the two wifi modules, but this had no effect.

Does the modem appear in lsusb?

No. Sorry for not checking that earlier.

This is all I have (lsusb)
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

And lspci
root@LEDE:/# lspci
00:00.0 PCI bridge: Device 0e8d:0801 (rev 01)
01:00.0 SATA controller: ASMedia Technology Inc. ASM1062 Serial ATA Controller (rev 01)

If there is nothing in dmesg then there is no need to worry about missing drivers. The modem must be detected and enumerated as an USB device before any drivers come into play.

Since this is a slot with support for more than just modems, the problem can be this:

The MC74xx modules are special. They have USB3 support, which works by repurposing some mini-PCIe pins which are normally used for PCIe. Unfortunately that means that they can fail in any mini-PCIe slot with PCIe or SATA signals. Most mini-PCIe form factor modems are USB2 only and do not have this problem.

But the problem is easy to solve: Just mask off the PCIe/USB3 specific pins with a piece of tape. See the picture in the link above. Note that you can cover the ground pins between the two signal pairs, as they are completely redundant. This makes it much easier to mask off all pins with a single piece of tape.

There might also be other signals which are incompatible with the mSATA support of this slot. I don't know. But the MC74xx has dual SIM support too, which also use a few more pins than your average modem. See the Sierra Wireless product docs.

Look in /sys/bus/usb/devices/ or /sys/kernel/debug/usb/devices to see if the modem is detected by the system. The /sys/class/net device(s) will only show up after a driver has bound, which is the next step.

1 Like

Thanks bmork, taping over the pins solved the issue! Happily connected using modemmanager now.

Hello, I'm exactly on the same configuration (Sierra Wireless MC7430 + Unielec U7621), I've flashed u7621-06-256M-16M-squashfs-sysupgrade.bin and install several packages, including kmod-usb-net-qmi-wwan and kmod-usb-net-cdc-mbim motioned above, and I've also taped the pins.
But so far, I've not succeeded to control and use this modem...

Is it possible without compiling my own image ? (which I'd really like to avoid)
Could you share a definitive list of needed packages preferably for MBIM mode ?
Any kind of information would be really appreciated ! (like config files, How-To, ...)

Thanks in advance !

dmesg | grep usb
ls -l /sys/bus/usb/devices/
cat /sys/kernel/debug/usb/devices

If the modem doesn't show up there, then there is something wrong with the bus connection and no software tricks will do any good. If it does show up, then we can look further for missing drivers etc.