Show duplicate entries of associated stations list


I have connected one client with 5ghz SSID. It should show entry on only 5ghz SSID on associated station list page but it also showing entry(including mac-address, ip-address, RSSI, RX, and TX) on 2.4ghz SSID.

Please find the attached screenshot.

Thanks in advance.


logread | fgrep xx:xx:xx:xx:xx:xx

to see if it, for example, associated but didn't disassociate.

...and by any chance, did you name the 2.4 and 5.4 GHz SSIDs identically?

Hi @lleachii

I have tried to give the VAPs name different for radio 2.4Ghz and 5Ghz. But i dont know why it is showing entry on both while connecting client only on 5Ghz.

Thank in Advance.

This is not original LuCI code, at least the column headings and other things have been modified. Does the same issue happen on unmodified LuCI? What is reported by iwinfo wlan0 assoclist vs. iwinfo wlan1 assoclist ?

Hi @jow,

I have verified with unmodified LuCI, output is same. Please find the below results:

root@OpenWrt:/# iwinfo ath0 assoclist
48:88:CA:24:21:4A  -38 dBm / -95 dBm (SNR 57)  1000 ms ago
        RX: 1.0 MBit/s                                  4095 Pkts.
        TX: unknown                                        0 Pkts.

root@OpenWrt:/# iwinfo ath1 assoclist
00:00:00:00:00:00  -95 dBm / -95 dBm (SNR 0)  0 ms ago
        RX: unknown                                        0 Pkts.
        TX: unknown                                        0 Pkts.

Thanks in advance.

This is clearly not an official OpenWrt build if you have interfaces named 'athX' and a command "wlanconfig". Is it the mac80211 stack? I've never seen an all zero "association" reported. When no stations are connected to an AP, iwinfo assoclist should return "no station connected".


Hi @mk24,

This is an official OpenWrt build and we didn't change anything in this.
We have "qcawifi" stack. We have connected client on ath0 i.e, 2.4GHz.

QCA Wifi is not part of official openwrt, therefor we can’t support it here. It is likely that the libiwinfo library needs fixing to properly work with the proprietary QCA driver you received but as we have neither access to the hardware nor to the drivers we cannot help with that.

1 Like

Hi all,

Thank for your reply.

for this issue what I have observed.
Suppose we have 4 VAPs(2 on 5GHz radio and 2 on 2.4GHz radio) having VAPs name VAP1: abcd, VAP2: qwerty, VAP3: 12345 and VAP4: test.

  1. If we are connecting client from VAP2 then associated list will show on last 3 VAPs i.e., one from which we have connected and after that only 2 VAPs left.
  2. If we are connecting VAP3 then associated list will show the last 2 VAPs because from one we have connected and after that only one VAP is left.

for this, I have checked in libiwinfo library and it seems everything is working fine.
We have also checked from htm side and it seems there is a problem Lua/Luci side. I think when we are sending data from Lua api to htm api file then this issues is happening.

Thanks in advance.

Hi all,

Anybody find this issue. If yes can you please share your comments and solution if you have. I have tried from my side and didn't get anything.

Thanks in advance.

It hard to "find this issue" - given we don't have a clue where your firmware came from.

I'd suggest asking on the forum were you got the firmware.

I have the exact same problem as yours. Were you able to fix it?

Hi @tanyasingh4ipnet,

No. I am not able to fix this issue.

The problem lies with the code that displays the Associated Station list. There is nothing wrong with 'iwconfig'.

@tanyasingh4ipnet, see above. This isn't an official supported OpenWrt.

Despite the OP insisting it was, the firnware includes software not bundled here.

Are you having an issue on official firmware?

I didn't have the official firmware but I had the same issue. I fixed it by modifying the code which displayed the Associated stations

1 Like

Hi @tanyasingh4ipnet,

Can you share the solution for the same.

Thanks in advance.