Should I disable "Enable VLAN functionality" option?

I dont need the vlan functionality since it is a household router (WRT3200ACM). Does disabling it reduces the overhead if I dont need any vlan function?

So my question is what happens when I check "Enable VLAN functionality"?

This device has two eth interfaces, one connected to the WAN port, and the other one connected to the internal switch that gives access to all the LAN ports.

So... yes, you can reconfigure your network and avoid using VLANs; however, I doubt that you are going to improve the performance at all.


Thanks, I disabled the Vlan, how do I configure and avoid using VLAN? do I delete the second VLAN?

Do not disable it. VLANs must exist inside the switch to keep the WAN and LAN networks separate. If you uncheck the box all 7 ports (5 external and two CPU) will be fully linked to each other like an unmanaged switch.

The switch is specialized hardware. It will act at the full speed of the Ethernet ports even with VLANs operational.

VLANs don't exist outside the switch if the ports are 'untagged'. You could make both CPU ports untagged but this would have really nil increase in performance and make it difficult to add more VLANs if you ever wanted to.

1 Like

Just configure WAN on eth0 and LAN on eth1.

I enabled it again. Thanks for the info.

1 Like

+1 for leaving VLAN enabled. I ran into strange problems when I did this myself. Be warned, this wasted about 5 of my hours trying several methods to get back into the web management interface (both wifi and all 4 switch ports stopped working for several reboots, when I dared to disable "Enable VLAN functionality"), just to finally find a way back in, and re-enable it again.

Myself, I consider it a "one-way street"; VLANs are something you can safely turn on without trouble (Network -> Switch -> "Enable VLAN functionality" checkbox) but disabling it again can make for trouble.

There's no harm in using just one VLAN ID (say, VLAN ID of "1", under "Port Status"), and all your LAN ports ("LAN 1", "LAN 2" ... "LAN n") are set to "untagged".

PS: I have a TP-Link Archer C60 v3, openwrt 22.03.5

Slightly off topic, but I tried with untagging both CPU ports (I have an R7800 with also two CPU ports) as I do not have VLANs and also in my theory that should work but it did not and I had to reset to defaults.

I did not research it further so maybe I did something wrong but best to leave everything as it is :slight_smile: