Shorten interface names - bonding

Ahoy friends.
Currently i am using vlans in addition to my bonding setup.
I got a 4 interface bonding and wanted to add vlans above 1000 as well. The problem:
When i create a bond, bonding- is appended, so there is no enough space left anymore to add a vlan above 900 because the interface won't work anymore.
So in my case, i wanted to choose "bond0" as the name, so OpenWrt creates an interface called "bonding-bond0". When i add vlans, i can only add vlans up to 9, because using 10, it would exceed the 15 characters limit, and the network interface doesn't work anymore.
So now i have reduced the name to bn0, which now allows vlan interfaces up to 999. i don't really want to change the name more, because it will make it very generic and no one will ever understand what that is.
Is there a way to remove this prepended "bonding-" from the interface name?

Examples:

config interface 'bn0'
        option proto 'bonding'
        option ipaddr '192.168.3.240'
        option netmask '255.255.255.0'
        list slaves 'eth0'
        list slaves 'eth1'
        list slaves 'eth2'
        list slaves 'eth3'
        option bonding_policy '802.3ad'
        option min_links '0'
        option ad_actor_sys_prio '65535'
        option ad_select 'stable'
        option lacp_rate 'slow'
        option xmit_hash_policy 'layer2'
        option all_slaves_active '0'
        option link_monitoring 'off'

This will still work.

config interface 'CCTV'
        option proto 'static'
        option ipaddr '172.20.224.1'
        option netmask '255.255.224.0'
        option device 'bonding-bn0.340'


This won't work anymore.

config interface 'WAN'
        option proto 'static'
        option ipaddr '172.20.64.1'
        option netmask '255.255.224.0'
        option device 'bonding-bn0.2000'


1 Like
1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.