Sharing via SAMBA problems-Spanish

I found under temp all these smbd files

root@GL-AR750S:/tmp# ls 
TZ                            lib                               smbd.1542302881.15825.6.core
api.socket-0                  lock                          run                           smbd.1542302882.15920.6.core
dhcp.leases                   log                           shm                           smbd.1542318584.22105.6.core
dnsmasq.d                     luci-indexcache               smbd.1542299981.1956.6.core   state
etc                           luci-modulecache              smbd.1542299986.2371.6.core   sysinfo
extroot                       nmbd                          smbd.1542299989.2469.6.core   tmp
hosts                         overlay                       smbd.1542299991.2765.6.core   wpa_ctrl_2666-1
html.socket-0                 resolv.conf                   smbd.1542301878.7020.6.core

And these the log files

root@GL-AR750S:/tmp/log# ls
cores     lastlog   lighttpd  log.nmbd  log.smbd  wtmp


Sorry for the ignorance, what should I restart Samba?

I will do it again and wil report the logs


But why do you think I can’t see any smb process running?

Those "smbd.*.core" files mean that samba is failing to start, and failing badly. Perhaps your device does not have enough RAM, perhaps there is a bug in SAMBA, ...

Open a SSH session and execute "logread -f", then open another one and run "/etc/init.d/samba restart", and watch the messages flow on the first session. Perhaps there is a clue there.

You're running the gl.inet flavour of OpenWrt ... it's probably better to ask in their support forum.

1 Like

Good morning Edu
The device has enough free RAM approx 40mega
I will try to run these two parallel sessions


I tried two run two sessions in parallel fro two devices but I couldn’t
Message in the second device: remote host reset the
How can I start two sessions from the same terminal?

Hi I managed with the two sessions

Nothing seems to come up

First session

root@GL-AR750S:~# logread -f
Fri Nov 16 10:58:23 2018 daemon.warn odhcpd[1754]: DHCPV6 SOLICIT IA_NA from 000100011d35051a9c35eb3644da on br-
Fri Nov 16 10:58:24 2018 daemon.warn odhcpd[1754]: DHCPV6 REQUEST IA_NA from 000100011d35051a9c35eb3644da on br-
Fri Nov 16 11:03:44 2018 dropbear[15127]: Child connection from
Fri Nov 16 11:03:54 2018 authpriv.notice dropbear[15127]: Password auth succeeded for 'root' from

Second session

root@GL-AR750S:~# etc/init.d/samba restart
-ash: etc/init.d/samba: not found
root@GL-AR750S:~# /etc/init.d/samba restart
root@GL-AR750S:~# /etc/init.d/samba restart
root@GL-AR750S:~# /etc/init.d/samba start  

The firmware came pre installed in the router

This is what i get when i try to reach the router/USB drive from windows

The device or resource (GL-AR750S) is not set up to accept connections on port "The File and printer sharing (SMB)".

Yes, exactly...


is there any way i can reinstall samba, or would this not help?


I would first install vanilla OpenWrt over the version supplied by the manufacturer, if the device supports it. Otherwise, I would contact the manufacturer.

Gracias Eduardo
I have already written to the technical support of the manufacturer but so far I didn’t get any answers.
Perhaps I could also try to reset the device to factory settings.
Would you kindly point me to a place where I could get a plain vanilla openwrt firmware for the router?
As you have surely noticed I am completely new to all this and I appreciate very much the support received


Be aware that it'll be very slow running Samba 4.x

I have now upgraded the firmware of the router to the newest available, therefore I need to reinstall everything from scratch
Could you please point me to a list of packages to install in order to have samba working properly

Now after upgrading firmware and having. A clean installation I still can’t connect to the router via windows.
However , as per Edu earlier message, I have exec simultaneously logread -f and restarted samba.

This is the message from the first session

Sat Nov 17 17:04:11 2018 kernel: [ 1052.522642] nf_conntrack: default automatic helper assignment has been turned off for security reasons
and CT-based firewall rule not found. Use the iptables CT target to attach helpers instead.

Is there anything I should be doing with firewall?

hi all
i still can no connect and i see again the "smbd.*.core" files in tmp and no "smbd" under ps
I have tried to flash the firmware with this bin file:

but i could not , i get an incorrect format error.