Sharing via SAMBA problems-Spanish

Good morning Edu
The device has enough free RAM approx 40mega
I will try to run these two parallel sessions


I tried two run two sessions in parallel fro two devices but I couldn’t
Message in the second device: remote host reset the
How can I start two sessions from the same terminal?

Hi I managed with the two sessions

Nothing seems to come up

First session

root@GL-AR750S:~# logread -f
Fri Nov 16 10:58:23 2018 daemon.warn odhcpd[1754]: DHCPV6 SOLICIT IA_NA from 000100011d35051a9c35eb3644da on br-
Fri Nov 16 10:58:24 2018 daemon.warn odhcpd[1754]: DHCPV6 REQUEST IA_NA from 000100011d35051a9c35eb3644da on br-
Fri Nov 16 11:03:44 2018 dropbear[15127]: Child connection from
Fri Nov 16 11:03:54 2018 authpriv.notice dropbear[15127]: Password auth succeeded for 'root' from

Second session

root@GL-AR750S:~# etc/init.d/samba restart
-ash: etc/init.d/samba: not found
root@GL-AR750S:~# /etc/init.d/samba restart
root@GL-AR750S:~# /etc/init.d/samba restart
root@GL-AR750S:~# /etc/init.d/samba start  

The firmware came pre installed in the router

This is what i get when i try to reach the router/USB drive from windows

The device or resource (GL-AR750S) is not set up to accept connections on port "The File and printer sharing (SMB)".

Yes, exactly...


is there any way i can reinstall samba, or would this not help?


I would first install vanilla OpenWrt over the version supplied by the manufacturer, if the device supports it. Otherwise, I would contact the manufacturer.

Gracias Eduardo
I have already written to the technical support of the manufacturer but so far I didn’t get any answers.
Perhaps I could also try to reset the device to factory settings.
Would you kindly point me to a place where I could get a plain vanilla openwrt firmware for the router?
As you have surely noticed I am completely new to all this and I appreciate very much the support received


Be aware that it'll be very slow running Samba 4.x

I have now upgraded the firmware of the router to the newest available, therefore I need to reinstall everything from scratch
Could you please point me to a list of packages to install in order to have samba working properly

Now after upgrading firmware and having. A clean installation I still can’t connect to the router via windows.
However , as per Edu earlier message, I have exec simultaneously logread -f and restarted samba.

This is the message from the first session

Sat Nov 17 17:04:11 2018 kernel: [ 1052.522642] nf_conntrack: default automatic helper assignment has been turned off for security reasons
and CT-based firewall rule not found. Use the iptables CT target to attach helpers instead.

Is there anything I should be doing with firewall?

hi all
i still can no connect and i see again the "smbd.*.core" files in tmp and no "smbd" under ps
I have tried to flash the firmware with this bin file:

but i could not , i get an incorrect format error.

The AR750S has NAND and NOR flash. With the plain vanilla OpenWrt image you can only use the latter flash type - initially only flashable via web based uboot. For details see here:


since i was not able to flash the last available open wrt image, i set the router back to factory settings
and now for some reason i can start samba.
the gl-ar750s is a travel router, so i have it connected like a repeater of my home router.

However i still have two (new) issues:

  1. when the windows laptop gets internet access through the router: In this case i can access the usb drive connected to the router, it shows up in windows file explorer/network , however once i enter in the usb drive it doesnt show any file.

  2. when the windows laptop gets internet access through the home router (to which the travel router is also attached) : In this case the router still shows up in windows file explorer network, but i can not access it
    It seems to me that in the latter case something should be done with the router firewall but i am not sure what.
    I found this , do you think this is what is needed? and if so how can i configure the routers firewall.
    Excuse my ignorance

    Configure /etc/config/firewall to open the following ports (if your LAN access is rejected by default):
    TCP 137 - NetBIOS Name Service
    TCP 138 - NETBIOS Datagram Service
    TCP 139 - NETBIOS Session Service
    TCP 445 - Microsoft Directory Services

config 'rule'
option 'src' 'lan'
option 'proto' 'udp'
option 'dest_port' '137-138'
option 'target' 'ACCEPT'

config 'rule'
option 'src' 'lan'
option 'proto' 'tcp'
option 'dest_port' '139'
option 'target' 'ACCEPT'

config 'rule'
option 'src' 'lan'
option 'proto' 'tcp'
option 'dest_port' '445'
option 'target' 'ACCEPT'

Somehow I have sorted everything out
But now I don’t know how to create a smb user
I don’t want to configure files
Can it be done from within luci?

This the template
I have added here two users, but to no avail, I can’t give them a password with smbpasswd in terminal because it doesn’t recognize the users kuku and luisa

This is my template smb config from luci

	netbios name = |NAME| 
	display charset = |CHARSET|
	interfaces = |INTERFACES|
	server string = |DESCRIPTION|
	unix charset = |CHARSET|
	workgroup = |WORKGROUP|
	browseable = yes
	deadtime = 30
	domain master = yes
	encrypt passwords = true
	enable core files = no
	guest account = nobody
	guest ok = yes
	invalid users = root
	local master = yes
	load printers = no
	map to guest = Bad User
	max protocol = SMB2
	min receivefile size = 16384
        null passwords = yes
	obey pam restrictions = yes
	os level = 20
	passdb backend = smbpasswd
	preferred master = yes
	printable = no
        valid users = kuku, luisa
security = share
	smb encrypt = disabled
	smb passwd file = /etc/samba/smbpasswd
	syslog = 2
        use sendfile = yes
	writeable = yes

I will start a new post since this last issue has nothing to do with the initial one from this post