Shared USB for Plex, Windows 11, R7800 OpenWrt+Samba

Hello, I have Samba installed, the USB is mounted and I can find it under my network drives. The problem is I am unable to add/remove files/folders to the drive.

Browseable - Checked
ReadOnly - Unchecked
Forec Root - Unchecked
Allowed Users - (blank)
Allow Guests - Checked
Guests Only - Unchecked
Inherit Owner - Unchecked
Create mask - 0666
Directory Mask - 0777
Vfs objects - Unchecked

Specific Error message:
"You need permission to perform this action"

Other odd thing of note, it is a 64gb usb drive, it shows up as Size 0 bytes

Eventually, I'd like to make this a plex drive.

I will never put anything special on this usb drive, so I don't care about controlling who accesses (I guess I don't want random people to access from outside my home, but I guess the router password will prevent that).

Is this a samba setting, or the permissions on OS level, for the mount point?

Reconfigure your share:

I encounter a bunch of road blocks when trying to edit Samba in Terminal.

root@OpenWrt:~# rm /tmp/luci-indexcache
rm: can't remove '/tmp/luci-indexcache': No such file or directory
root@OpenWrt:~# /etc/samba/smb.conf.template
-ash: /etc/samba/smb.conf.template: Permission denied
root@OpenWrt:~# /etc/passwd
-ash: /etc/passwd: Permission denied
root@OpenWrt:~# config 'samba'
-ash: config: not found
root@OpenWrt:~# /etc/config/samba
-ash: /etc/config/samba: not found

This seemed to work, I can now create a folder and add music to it, plus i played a song from the usb drive.

Note: for people like me, each of these can only be pasted one at a time.

chmod -R 777 /mnt/sda1
chown -R nobody /mnt/sda1

chmod -R 777 /mnt/sda1
chown -R nobody /mnt/sda1

You're doing it wrong.


you might want to add those to the rc.local, openwrt have/had a tendency to change those auths back, on every boot.

The -R might not be required, try doing it again, without it.