Setup wifi ap + sta

I am trying to customise wifi mode ap + sta. But when mode sta scanning and don't find "wifi-home", mode ap don't active. This is log

Please press Enter to activate this console.
[    9.423499] kmodloader: loading kernel modules from /etc/modules.d/*
[    9.519910] ip6_tables: (C) 2000-2006 Netfilter Core Team
[    9.537439] Loading modules backported from Linux version wt-2017-11-01-0-gfe248fc2c180
[    9.545564] Backport generated by backports.git v4.14-rc2-1-31-g86cf0e5d
[    9.555658] ip_tables: (C) 2000-2006 Netfilter Core Team
[    9.570623] nf_conntrack version 0.5.0 (2048 buckets, 8192 max)
[    9.642762] xt_time: kernel timezone is -0000
[    9.706196] mt76_wmac 10300000.wmac: ASIC revision: 76280001
[   10.729316] mt76_wmac 10300000.wmac: Firmware Version: 20151201
[   10.735340] mt76_wmac 10300000.wmac: Build Time: 20151201183641
[   10.757228] mt76_wmac 10300000.wmac: firmware init done
[   10.986677] PPP generic driver version 2.4.2
[   10.996393] NET: Registered protocol family 24
[   11.074298] kmodloader: done loading kernel modules from /etc/modules.d/*
[   12.157890] urandom_read: 5 callbacks suppressed
[   12.157900] random: jshn: uninitialized urandom read (4 bytes read)
[   15.765529] rt3050-esw 10110000.esw: link changed 0x00
[   19.250601] rt3050-esw 10110000.esw: link changed 0x01
[   21.431927] br-lan: port 1(eth0) entered blocking state
[   21.437313] br-lan: port 1(eth0) entered disabled state
[   21.442962] device eth0 entered promiscuous mode
[   21.483140] br-lan: port 1(eth0) entered blocking state
[   21.488526] br-lan: port 1(eth0) entered forwarding state
[   21.494213] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[   22.497327] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   24.897278] IPv6: ADDRCONF(NETDEV_UP): ap: link is not ready
[   25.551368] IPv6: ADDRCONF(NETDEV_UP): sta: link is not ready
[   76.427403] random: crng init done


config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option ula_prefix 'fd20:a001:3b30::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ip6assign '60'

config device 'lan_dev'
        option name 'eth0'
        option macaddr '40:a3:6b:c4:72:ee'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '0'

config interface 'ap'
        option proto 'none'

config interface 'wan'
        option proto 'dhcp'
        option hostname 'mn-audio'


config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/10300000.wmac'
        option htmode 'HT20'
        option country '00'
        option legacy_rates '1'
        option disabled '0'
        option channel '1'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'OpenWrt'
        option network 'ap'
        option ifname 'ap'
        option encryption 'psk2'
        option key '12345678'

config wifi-iface
        option network 'wan'
        option ssid 'tungdzok'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'sta'
        option bssid 'D2:B1:28:89:C5:01'
        option key '12345678'
        option ifname 'sta'


config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

I think problem :
[ 24.897278] IPv6: ADDRCONF(NETDEV_UP): ap: link is not ready
[ 25.551368] IPv6: ADDRCONF(NETDEV_UP): sta: link is not ready
How to fix this problem ? Thanks !!!

Can’t start AP mode until STA is associated. See the Travelmate package for one resolution approach.


Thanks for responses !!!
I installed luci-app-travelmate package and click Services/Travelmate/Wireless Stations/Scan radio0 (11g), I encounter a problem. I can't scan wifi.

Help me, please !!! Thanks.

That's a known bug which has been fixed in master, please update your travelmate packages to latest master, see first post for download links: Travelmate support thread


What about Broadcom chip?

1 Like

Thanks, I have solved the problem!!!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.