Setup OpenWRT for PPPoE , Vigor, Telekom DSL

Hello everyone,

trying to set up MR8300 (OpenWRT 22.03) to receive internet over PPPoE via a Draytek Vigor 160 series modem (IP 192.168.99.1). The modem has DSL sync, VLAN 7 enabled and is configured in bridge mode.

So far I tried following the OpenWRT ISP settings and also two different threads here but got "Unable to complete PPPoE Discovery" error.

I'll post my current network config (getting internet via a connected Fritzbox, WAN is here configured on eth1.3) and also one network config I tried so far without success (I tried several device configurations, the one below is probably rather wrong regarding the dsl device, but similiar to others I tried)

Could someone give me directions how to change this to work with the PPPoE and the Draytek Modem?

config globals 'globals'
option ula_prefix '*************/48'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '5'
	option vid '5'
	option ports '0t 0t 4'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '4'
	option ports '0t 0t 1 2 3'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'
	option ports '0t 0t 5'

config device
	option type '8021q'
	option ifname 'eth0'
	option vid '5'
	option name 'eth0.5'

config device
	option type '8021q'
	option ifname 'eth0'
	option vid '4'
	option name 'eth0.4'

config device
	option type '8021q'
	option ifname 'eth1'
	option vid '3'
	option name 'eth1.3'

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'badlan'
	option device 'br-badlan'
	option proto 'static'
	option ipaddr '192.168.11.1'
	option netmask '255.255.255.0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.22.1'
	option netmask '255.255.255.0'

config interface 'wan'
	option device 'eth1.3'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.99.100'
	option gateway '192.168.99.1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.4'

config device
	option name 'br-badlan'
	option type 'bridge'
	list ports 'eth0.5'

Config I tried without success


config globals 'globals'
	option ula_prefix '*************/48'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '5'
	option vid '5'
	option ports '0t 0t 4'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '4'
	option ports '0t 0t 1 2 3'

config device
	option type '8021q'
	option ifname 'eth0'
	option vid '5'
	option name 'eth0.5'

config device
	option type '8021q'
	option ifname 'eth0'
	option vid '4'
	option name 'eth0.4'

config device
	option type '8021q'
	option ifname 'eth1'
	option vid '3'
	option name 'eth1.3'

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'badlan'
	option device 'br-badlan'
	option proto 'static'
	option ipaddr '192.168.11.1'
	option netmask '255.255.255.0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.22.1'
	option netmask '255.255.255.0'

config interface 'wan'
	option ifname 'dsl0.7'
	option netmask '255.255.255.0'
	option ipaddr '192.168.99.100'
	option gateway '192.168.99.1'
	option proto 'pppoe'
	option username '@@@'
	option password '@@@'
	option device 'dsl0.7'
	option ipv6 'auto'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.4'

config device
	option name 'br-badlan'
	option type 'bridge'
	list ports 'eth0.5'

config device
	option name 'dsl0.7'

config dsl 'dsl'
	option annex 'b'
	option tone 'bv'
	option xfer_mode 'ptm'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

dsl information

ModeVDSL2
Profile17a
AnnexANNEX B

Do yourself a favour and upgrade to 23.05.0 first, which migrates ipq40xx to DSA and fixes many fundamental issues with the switch driver and VLANs for this hardware.

This should be the vigor side (should be very similar for yours):

Once upgraded to 23.05, you can just use wan.7 (or use bridge-vlan-filtering):

2 Likes

Yes VLANs were very problematic on the ipq4019 until recently, because swconfig had trouble with that chip's internal switching scheme.
I would start with a default configuration, set up your pppoe using Device wan.7 instead of wan and confirm that that can connect to the Internet. Finding that to work you can then rebuild your other networks in DSA format.

1 Like

Thanks for the answers.
Not successful so far.

  • set the bootloader to read 5 MB
  • have installed openwrt-23.05.0-ipq40xx-generic-linksys_mr8300-squashfs-factory on the 2nd firmware slot
  • configured WAN as shown with correct user/pass

But get:

Error: Unknown error (USER_REQUEST)
Error: Connection attempt failed

config device
        option name 'wan'
        option macaddr '***'

config interface 'wan'
        option device 'wan.7'
        option proto 'pppoe'
        option username '***'
        option password '***'
        option ipv6 'auto'

Since the Vigor has the LAN set to static IP 192.168.99.1 i also tried

config interface 'wan'
        option device 'wan.7'
        option proto 'pppoe'
        option username '***'
        option password '***'
        option ipv6 'auto'
        option ipaddr '192.168.99.100'
        option netmask '255.255.255.0'
        option gateway '192.168.99.1'
        option defaultroute '0'
        option peerdns '0'

with the same result.

If your draytek is already configured to do the vlan tagging (as you wrote in your first post) there's no need to use vlan tagging on the wan interface in Openwrt.

And please remove all IP related stuff on the wan interface (PPPoE runs on OSI layer 2)

So this should do:

config interface 'wan'
        option device 'wan'
        option proto 'pppoe'
        option username '***'
        option password '***'
        option ipv6 'auto'
2 Likes

@kirdes That was the final step to dial in, thank you!

Now I have a lot of configuratio to redo but would close here I guess, thanks again!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.