Setup multiple vlans and now DHCP is dead (DHCP config attached)

Here is my DHCP config:

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'

here are my vlans (simply broke them apart to have flexibility to add an extra WAN in the future). The idea is to re-join them and make sure all is well before I proceed further.

Screenshot_2018-12-21_16-00-41

And how did you configure your networks at "/etc/config/network"?
How are those VLANs being attached to your networks, specially "LAN"?

Your LAN Physical Settings should have all three eth0.1, eth0.2, and eth0.3 checked. But not eth0.

That establishes a software bridge to make them all work as LAN ports. Later when you want to use one for other things you would create a new network interface and move the eth0.x over to it.

Yes, overlooked eth0 (old screenshot and was fixed at the time of posting).

I would think everything would have been as it was before (other than tagged vs untagged on CPU), but it doesn't seem to be the case. I can only connect to the router with a static IP from the computer (no DHCP function in the router).

Here is the network config:


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdbf:c62d:b040::/48'

config interface 'lan'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.2.1'
	option _orig_ifname 'eth0 wlan0'
	option _orig_bridge 'true'
	option ifname 'eth0.2 eth0.3 eth0.4'

config interface 'wan'
	option proto 'dhcp'
	option metric '10'
	option _orig_ifname 'eth1'
	option _orig_bridge 'false'
	option ifname 'eth1'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0t 1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '0t 2'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'
	option ports '0t 3'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '4'
	option ports '0t 4'

config interface 'wan2'
	option proto 'dhcp'
	option metric '20'