Setup IPv6 for LAN

I know the title is a bit broad but I'm trying to configure IPv6 on my router as a whole but I'm having a few issues.

This is the guide I have been using is > https://openwrt.org/docs/guide-user/network/ipv6/start

Essentially I want to pass all the IPv6 checks on > https://test-ipv6.com/

/etc/config/network

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ifname 'eth0.5'
	option broadcast '192.168.1.255'
	option igmp_snooping '1'
	list dns '192.168.1.1'
	option stp '1'
	option ip6assign '64'

config interface 'wan'
	option ifname 'eth1.20'
	option proto 'pppoe'
	option password 'password'
	option username 'username@domain.com'
	option mtu '1492'
	option ipv6 'auto'

/etc/config/dhcp

config dhcp 'lan'
	option interface 'lan'
	option limit '254'
	option leasetime '12h'
	option start '10'
	option ra 'server'
	list dns '192.168.1.1'
	option dhcpv6 'server'
	option ra_default '1'
	option ra_management '1'

I seem to be having DNS lookup problems on IPv6. If I disable IPv4 in Windows 10 and use only IPv6 and run the nslookup bbc.co.uk command from Windows command promt I get the following:-

C:\Windows\system32>nslookup bbc.co.uk
DNS request timed out.
    timeout was 2 seconds.
Server:  UnKnown
Address:  fdcf:15da:492:1::1

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
*** Request to UnKnown timed-out

What am I missing?

Many thanks in advance.

I'm trying to get IPv6 connectivity too.

Are you able to ping IPv6 services? Say, what does

ping6 ipv6.google.com

or

curl -6 ifconfig.co

say? Also, are you able to SSH in your router? Is there difference doing those from the router vs. from your computer?

1 Like

This is wrong. The limit is the amount of leases, not the last IP to be leased. So if you want to lease from 10-254, you use start=10 and limit=244.

For the rest of troubleshooting, better post the output of these commands:

uci export network; uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip -4 addr ; ip -4 ro ; ip -4 ru; \
ip -6 addr ; ip -6 ro ; ip -6 ru; \
iptables-save -c; ip6tables-save -c; \
ls -l  /etc/resolv.* /tmp/resolv.*; head -n -0 /etc/resolv.* /tmp/resolv.*
1 Like