Setup difference between boot and rollback?

OpenWrt is an awesome project, I am an enthusiastic user for many years. (Thought after everything works like intended I tend to forget the details of the workings :sweat_smile:). My newest project involves a Xiaomi Redmi Router AX6S in which I want the WAN port to be used as a LAN and which relays the wifi dhcp requests so I can see all devices on the network in the main server leases.

I have this working, but with the weird behavior that my setup only works after I trigger a rollback. Upon a reboot the setup fails to pass the DHCP traffic to the WAN port until I change something in my VLAN which triggers a rollback, after which all works fine?!

I tried to find any differences between the 2 by running a uci show after booting and again after the rollback and diffing the 2 outcomes. Here are no changes, so I am starting to suspect some kind of timing/order issue upon booting?

To get the setup working I added option network 'lan' to my wireless config in etc\config\wireless and added all ports to a bridge device and put them in a single VLAN.
Upon boot my WAN port does not relay DHCP, and after a rollback it does.

Anyone any clues on how to tackle this one? I tried comparing the setups, manually restarting and toggling the interfaces, network, services; but I have not been able to manually trigger something which gives me the same results as a rollback :roll_eyes:.

Any help would be very appreciated :pray:

It sounds like you're setting up a dumb AP and you want all of the Ethernet ports to be untagged and hardware switched into the same network (the lan).

This is a DSA kernel, where the physical ports are named "lan1" "lan2" etc and "wan". To do this, add the wan physical port into the existing br-lan, and delete the wan and wan6 interfaces so the physical port is only referenced in one place (br-lan).


It did not exactly help me debugging the issue which I had, but since I had been playing around to get things to work and your solution sounded quite straight forward it did make sense to just redo the setup.
Works perfectly, just what I wanted.

Thank you! :pray: :100:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.