Setup as "dumb" AP, but with working LED's?


Recently put openwrt back on to my TP-Link Archer C6 EU V2. (last time I tired this I managed to brick the router and ended up buying a new one you can tell, I'm not great with this stuff).

So far so good.

I've followed the guide to set it up as a "dumb AP", and enabled only my 5ghz wireless on a high channel number (that was the whole point of using openwrt, because I need a totally clear channel for oculus airlink with my quest 1), and it's working well.

I then went into the "switch" settings and swapped the WAN port from VLAN2 to VLAN1, so that I can use the WAN port as another in dumb AP mode, the WAN port was not doing anything at all....wasn't working to provide internet to the other devices, and wasn't working as a normal port to connect another device if I put my internet cable to one of the other ports.

Anyways, everything is working, I now have the ethernet cable from my main home router connected to WAN port, even though it's acting as just another port, so I could switch it into any of the others, and switch them all round, doesn't matter....I have my PC, TV, AVR, UHD Player all plugged in to the other ports.....everything is getting internet. Wi-Fi is working, and quest gets internet fine and has a much better connection to my PC.

Only thing is.....the LED's!!!!

Power LED works fine, 5Ghz Wi-Fi seems to function as intended, but I get no other LED functions for the cabled devices.

Is there either a way to restore LED functions correctly?

Ideally, I'd Like :-

LED 1 = POWER (keep as it is)
LED 2 = 5Ghz Wi-Fi, ON when link active (this is normally for 2.4Ghz Wi-Fi, but may as well use it)
LED 3 = 5Ghz Wi-Fi, flash when activity with my quest
LED 4 = LAN ports, ON when link active for any device connected to any of the normal LAN ports, flashing when activity on those devices
LED 5 = WAN port (even though it's no longer a WAN port), ON when link active on this specific port (i.e. the ethernet cable is connected to my main that if I unplug, or the cable has a fault for example, the light will turn off).
LED 6 = not's for WPS normally, but I can't think of another use for this LED (suggestions).

Would this be possible in DUMB AP mode? or am I trying to do something which doesn't make sense in the IT world?

Any help would be much appreciated, or any suggestions for a different way to give some kind of functionality to the LED's?

I'm not sure why the LEDs are not working in the first place but have you tried looking in Luci > System > LED configuration to add a LED action in there?

Here's more on the LED configuration.

1 Like

You also need to move the WAN port from the WAN-Interface to the LAN-interface , ie add it to br-lan

I checked my archer c6 v2 configured as dump ap. I have set up 2 lan ports 3,4 inside the guest net, and lan ports 1,2 and wan port inside the normal lan. I use the lan led for guest net, the wan led for normal private lan.

The order of ports when looking at the back of the router is from left to right wan, lan1, lan2, lan3, lan4.

In the led config you can specify a lan port mask. For my guest net this is port3,4 =mask 0x30, for my lan net this is ports wan, lan1, lan2 = mask 0x0d.
It looks like wan port is 3rd bit of second half byte (0x02), and then the lan ports are the bigger bits to the left starting with lan1 = 0x04, lan2 = 0x08, lan3 = 0x10, lan4 = 0x20.

Ok, thanks for the replies. This is all way over my head though, so I'm just gonna keep it with lights not working. Router works and wifi works, that's the main thing.

I have to correct my last post:
for ports wan, lan1, lan2 bit mask is 0x0e, the rightmost bit 0x01 is for the cpu.

I now changed the led setup to use the wps led for the "uplink", the wan led for private lan clients and the lan led for guest lan clients.

This is of course just a nice gimmick to play with :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.