Settings to Internet id:300 T-Mobile


I am trying to set up my internet connection from working Netgear R7800 Firmware to Openwrt.
In the original firmware from Netgear it took me 5 minutes to set it up :grimacing:

But with the Openwrt, wich looks much nicer than the DD alternative, it wont work :confused:

These are my settings now, and the original working Netgear version.

Does anybody know where i am missing the one bit off ??

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
1 Like

T-Mobile would suggest some kind of cellular WAN connection (LTE, 5g, ...), but I don't see how that plays a role in your screenshots, nor what you mean by id:300 in this context (VLAN ID? but that would be wired).

1 Like

On the switch page, change the VLAN ID of the second line from 2 to 300. Change the WAN port from untagged to tagged in that VLAN. This will cause packets tagged 300 received from eth0.300 to be accepted by the switch and switched through to the WAN port, and leave the switch with the tag still in place for the modem.

Then go to the network interfaces page and click edit on wan. Change the device from eth0.2 to eth0.300. Repeat for wan6 if the ISP uses IPv6.

I guess the OP is using a wired or fiber service from Telekom in Germany. In the USA we have only the T-Mobile USA division and it is all wireless.


Just off the top-o-my head I see that the wan doesn't appear to have a ipv4 address and rx 0pkts confirms it's not communicating. You probably have some sort of issue with the wan. How to fix: I don't know but others will

Edit: If mk24's suggestion works then he beat me to it.

You are my hero for this weekend :partying_face: :hugs: :sunglasses:
This was exactly what did the trick :ok_hand:

For people searching to get there router (Netgear R7800) settings on OpenWRT
The settings for T-Mobile Internet glasfibre with media converter;
This works for me !!

Interfaces WAN6
Interfaces WAN

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.