Settings reset after reboot EA6350 V3


I flashed NoTengo's build on my ea6350 V3 router, it works fine until I install any packages. After that whenever I reboot it resets the whole settings to default.

On default Overlay has 39Mb space, And after settings everything up with packages it goes down to around 25MB. There are no errors of overlay in the log.

I flashed factory fw, not the sysupgrade. Have tried different versions but it's still the same issue.

NoTengoBattery v3.0.3

Then you should probably report it to NTB.

I did but he's not very active on the actual thread. Also the router is old so can't install the latest FW due to some DSA setting issue, I've read somewhere.

Any help?

I don't know the differences between the official 21.02 release and NTB's version. Perhaps there's a newer build from him based on 22.03.
Maybe you like to try the current 22.03 release from
Probably you can't keep the settings from 21.02 and have to configure it new from scratch.


It had nothing to do with the firmware, it was an outdated script from Openwrt guide:

The automount script is the culprit. It removes Mount point of /Overlay, so when you reboot the router it doesn't mount overlay. That's why the router goes back to factory settings. That stupid script cost me 10 hours and 3 days of troubleshooting just to find out it wasn't the firmware.

What I did now? I installed NTFS-3G, and put:
ntfs-3g /dev/sda2 /mnt/usb-ntfs -o rw,big_writes
In System/Startup. Now when I reboot, it mounts overlay as well as my HDD automatically. It's perfect now!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.