Settings lost on reboot (fresh install 19.07.7 on ER-X)

Moderately-experienced Linux user here. First-time OpenWrt user. I purchased ER-X and successfully flashed 19.07.7 factory image and sysupgrade image without any problems. After customizing all the setting to my needs, I needed to do a reboot. Upon reboot, all settings have reset (root password empty, extra installed packages gone, etc.). I am looking at my file systems and don’t think I have the correct partitions set up. See below:

BusyBox v1.30.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 OpenWrt 19.07.7, r11306-c4a6851c72
root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 1.8M      1.8M         0 100% /rom
tmpfs                   123.9M    240.0K    123.6M   0% /tmp
/dev/ubi0_1             213.4M      6.0M    202.6M   3% /overlay
tmpfs                   123.9M     80.0K    123.8M   0% /tmp/root
overlayfs:/tmp/root     123.9M     80.0K    123.8M   0% /
tmpfs                   512.0K         0    512.0K   0% /dev

root@OpenWrt:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00080000 00020000 "u-boot"
mtd1: 00060000 00020000 "u-boot-env"
mtd2: 00060000 00020000 "factory"
mtd3: 00300000 00020000 "kernel1"
mtd4: 00300000 00020000 "kernel2"
mtd5: 0f7c0000 00020000 "ubi"

root@OpenWrt:~# cat /etc/mtab
/dev/root /rom squashfs ro,relatime 0 0
proc /proc proc rw,nosuid,nodev,noexec,noatime 0 0
sysfs /sys sysfs rw,nosuid,nodev,noexec,noatime 0 0
tmpfs /tmp tmpfs rw,nosuid,nodev,noatime 0 0
/dev/ubi0_1 /overlay ubifs ro,noatime,ubi=0,vol=1 0 0
tmpfs /tmp/root tmpfs rw,noatime,mode=755 0 0
overlayfs:/tmp/root / overlay rw,noatime,lowerdir=/,upperdir=/tmp/root/upper,workdir=/tmp/root/work 0 0
tmpfs /dev tmpfs rw,nosuid,relatime,size=512k,mode=755 0 0
devpts /dev/pts devpts rw,nosuid,noexec,relatime,mode=600,ptmxmode=000 0 0
debugfs /sys/kernel/debug debugfs rw,noatime 0 0

What do you think is going on? I am considering upgrading to snapshot. I was already considering it as the latest snapshot apparently address the mtk_soc_eth errors that I do occasionally see in the logs.


@Thesnowdog, welcome to the community!

I suggest using the sysupgrade file and flashing over the device a 2nd time - then testing. Let us know your results.

I ended up upgrading to snapshot and things are working beautifully.

If you'd rather run a stable release, you can flash the 21.02 builds that the buildbots have been crunching on. Those don't have that mtk_soc_eth issue solved as well. At this point they're mostly identical to master as well.

Will keep that in my mind if I run into any instability with snapshot. Thanks

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.