Setting Xiaomi Mi Router 4 as Dumb AP

I ordered a few Xiaomi Router 4's, Followed the Guide to installing OpenWRT on them with no issues (besides the Firmware OpenWrt Upgrade link being wrong, I found the upgrade file by going back through the url , and finding the proper link for xiaomi_mi-router-4-squashfs-sysupgrade.bin
All is good at this point.
Now I've read the guides for turning it into a dumb ap on the official OpenWRT documents online, following Step 8.

Use the main router for DHCP. Same page again, now the DHCP Server tab. Should be at the General Setup sub-tab. (In version 18.06 and earlier of LuCI, no tabs: just scroll down.) Ensure the Ignore interface checkbox is checked.

Use the main router for DHCP doesnt exist, or I am inept and can't find the option..
Once I disabe the DHCP server, I can only connect to the router if I manually set my IP within it's range on my PC (windows and rebooted in linux too). I can't get an IP from it. Is there a DHCP Relay option or something I need to enable??
setting my main router as DHCP server seems to not be an option as far as I can see in the GUI.
I'm stuck.
I know that the newer version of OpenWRT use DSA, so perhaps the wiki is out of date?
IDK what I'm doing wrong besides not being able to set my main OPNsense router as the DHCP server (it serves 3 separate networks DHCP no problem)

The document is just poorly worded. What they mean is it tells you how to use the main router for DHCP, not that you need to find an option called "Use main router for DHCP" (Someone should go over the documentation and rewrite most of it, to be quite frank)

Is your main router connected to the LAN-ports or the WAN-port?

1 Like

The default configuration of a main router is that it is the LAN network's DHCP server. So you don't have to re-configure anything there.

Turning off the DHCP server in the dumb APs is important so you don't have multiple conflicting DHCP servers on the network.

Of course with the DHCP server turned off, the router is difficult to operate stand-alone. It needs to be connected to the larger network that includes a DHCP server. Do not apply any changes until you get to step 14, then after the changes are applied, you can connect the dumb AP to your house network.

1 Like

[Rack] Main router(OPNSense) LAN port -> [Rack] Gigabit Switch for internal LAN -(ethernet cable)> LAN port 1 on Mi R4.

OK, I'll reset, and try this way, thx.

Have you tried this?

I tried this and it works!

....the OP themselves already linked to that article in the very first post to this thread.

1 Like

Thanks anon who updated the wiki, it works as intended now.

Should I untick
Authoritative [ ]

This is the only DHCP in the local network

under DHCP & DNS as well?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.