Setting up Wi-Fi repeaters with multiple SSIDs with separated private, tor and guest network

Hello...

I'm trying to achive the goal of this guide:

But it does not work for OpenWRT 21.02 with DSA Switch... VLANs are configured different.
I can't figure it out how to configure the interfaces and devices.
Can anybody help me to understand what need to be done differently form this guide on the newest release?

You'd best follow up-to-date articles:

Hello... I have finally made it... I'll post my /etc/config/network:
In this setup, I have the main router using LAN1 port is untagged on iot VLAN (id 107). The LAN2 and LAN3 are untagged on VLAN ID 1.

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config interface 'lan'
        option device 'br-lan.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'lan1:t'
        list ports 'lan2:u'
        list ports 'lan3:u'

config bridge-vlan
        option device 'br-lan'
        option vlan '30'
        list ports 'lan1:t'
        list ports 'lan2:t'
        list ports 'lan3:t'

config bridge-vlan
        option device 'br-lan'
        option vlan '107'
        list ports 'lan1:u'
        list ports 'lan2:t'
        list ports 'lan3:t'

config interface 'guest'
        option device 'br-lan.30'
        option proto 'static'
        option ipaddr '192.168.30.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option delegate '0'
config interface 'iot'
        option device 'br-lan.107'
        option proto 'static'
        option ipaddr '192.168.9.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option delegate '0'

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.