Setting up the Epson L222 as a network scanner

Hello! I was able to use my Epson L222 MFP as a printer on OpenWrt. However, I'm having trouble figuring out how to use it as a scanner.

How are you connecting this to OpenWrt? USB? Network (wifi/ethernet)?

The MFP is connected to the router via USB

Did you try this:
https://openwrt.org/docs/guide-user/services/scanner_server/saned

for some reason, I can't connect via ssh, and through the browser, too, at the address. Somehow openwrt does not work stably.

saber716rus@rosa-xn4gdg ~ [255]> ssh root@192.168.1.93
ssh: connect to host 192.168.1.93 port 22: No route to host
saber716rus@rosa-xn4gdg ~ [255]>

How are you trying to connect to OpenWrt? What device are you using for OpenWrt?

Why such an address? The router is working in repeater mode, but there were no such problems the day before yesterday. I can't figure out what the problem is yet.

I was about to ask you this... did you change the address?

asus ax53u
version: 23.05.3

Are you using relayd? Or some other method?
Running services such as p910nd and saned on a device with relayd is not necessarily going to produce reliable results -- relayd is a bit of a hack and may have odd behaviors when combined with other services.

If you're unable to connect currently, I'd recommend that you use failsafe mode and dump your current configuration for review.

After entering failsafe mode...

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

mount_root
ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

I use relayd. setting up the p910nd did not lead to a deterioration in the relay operation, but with sane it seems to have led. And the print seems to have fallen off too because of the save setting. I did it according to the instructions, but the scanner is not visible for the router.

root@OpenWrt:~# mount_root
root@OpenWrt:~# ubus call system board
{
        "kernel": "5.15.150",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "ASUS RT-AX53U",
        "board_name": "asus,rt-ax53u",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.3",
                "revision": "r23809-234f1a2efa",
                "target": "ramips/mt7621",
                "description": "OpenWrt 23.05.3 r23809-234f1a2efa"
        }
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd27:6811:703a::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'
        option type 'bridge'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'
        option type 'bridge'

config interface 'wwan'
        option proto 'dhcp'
        option device 'phy1-sta0'

config interface 'repeater'
        option proto 'relay'
        list network 'lan'
        list network 'wwan'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option channel 'auto'
        option band '2g'
        option htmode 'HE40'
        option country 'RU'
        option cell_density '0'
        option noscan '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'SecNET'
        option encryption 'sae-mixed'
        option key ''
        option wpa_disable_eapol_key_retries '1'
        option network 'lan'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
        option channel 'auto'
        option band '5g'
        option htmode 'HE80'
        option country 'RU'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'SecNET'
        option encryption 'sae-mixed'
        option hidden '1'
        option key ''
        option wpa_disable_eapol_key_retries '1'
        option network 'lan'

config wifi-iface 'wifinet2'
        option device 'radio1'
        option mode 'sta'
        option network 'wwan'
        option ssid 'SecNET'
        option bssid '52:FF:20:8C:6C:50'
        option encryption 'sae'
        option key ''

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'
        list network 'wwan'
        list network 'repeater'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

root@OpenWrt:~# 

I've raised the question here about using the 802.11n protocol with the keenetic router, at least optionally.

I don't want to buy another keenetic router when there is an Asus ax53u. I would like to have both a repeater and a print server with a network scanner.

Bridge statements do not belong in the interface definitions. Remove those lines.

Remove the device above.

Reboot and see if that helps anything.

Did. But there is one nuance that I noticed. I am currently sitting next to the repeater (ax53u), then logically I should hook up with the repeater, but this does not happen even after removing the wan interfaces and the device from the wwan interface. But I also noticed that today I connect to the router without any problems, both through the browser and via ssh, and these are config edits.

Not necessarily. If your other APs are running at a power level that is higher than necessary for the proximity and floorplan, your devices may prefer to stay with another AP.

That said, I'm not an expert with the relayd/wds methods of making repeaters -- I don't use these myself. And I've never tried SANE. I think the problem was probably coincidental, but you might want to try making a backup, and then configuring from scratch. You could take one of two approaches:

  1. configure SANE first with the AP wired to the network, then try adding the repeater functionality.
  2. configure the repeater functionality first, then install SANE.

I also come to this conclusion that because of an accidental mistake. This problem has appeared. But before the error, the Internet was more stable. This morning, I had to reboot both the repeater and the main router to restore the network's functionality. I also noticed that when you connect to the repeater access point, there is no way to connect via a browser, and if you are connected to the access point of the main router, then you connect calmly. Again, this was not the case before the error.

when connected to the AX53U. then the Internet is not working well. if you reboot, then everything is OK.

I opened a bug on github. Through communication and self-exploration, I found out the following. When switching to the main router, the problem manifests itself, especially with regard to the 5GHz access point.