Setting up Netgear EX6150v2

Netgear EX6150v2
ARMv7 Processor rev 5 (v7l)
OpenWrt 22.03.0 r19685-512e76967f
LuCI openwrt-22.03 branch git-22.245.77528-487e58a|
Kernel Version 5.10.138

I have compared the settings with my old wireless bridge Archer C7 OpenWrt 18.06.5, looks there is a big difference and I am unsure how to configure this repeater.

Is there a tutorial how to do it?

I have changed the network already to the fritzbox-network 192.168.178.x The Fritzbox is the DHCP-server

Primary goal is to get a wifi-connection via Ethernet for a dvb-box

The EX6150v2 extender should be a range extender for a Netgear Nighthawk X4S R7800 with OpenWrt 18.06.1. I know 18.06 is very outdated, but to upgrade all the openwrt routers I use is a big challenge, it is on the todo list, but not now.

I prefer editing the config files via ssh and vi, sometimes hard to find in luci compared to edting a text-file. I never configured a repeater, so I am very unsure what is needed. I need 2.4GHz only.

If the box doesn't need access to the rest of your LAN, go to the wifi page, and do a scan -> join.
Put the connection in the wan fw zone, and you should be good to go.

We can assume this for the beginning. What you suggested didn't work, probably my mistakes.

Qualcomm Atheros IPQ4019 802.11bgn
Channel: 11 (2.462 GHz) | Bitrate: ? Mbit/s

Qualcomm Atheros IPQ4019 802.11nac
Device is not active

I assume I have to do the join with "Qualcomm Atheros IPQ4019 802.11bgn" since I need 2.4GHz only and "Qualcomm Atheros IPQ4019 802.11nac" can be ignored.

After the join I saw

SSID: PaW4 | Mode: Master
BSSID: 78:...:65 | Encryption: WPA2 PSK (CCMP)

PaW4 is the master, but BSSID starting with 78 is this extender and not the master.

Since it didn't work, I had a look at my working bridge router C7 and configured the following with an editor:

removed, because below is a working version.

When I search for wifi nets with my mobile phone, I don't see PaE4 (E like extender)

Totally confused now.

I am writing with a Raspberry PI400 and Ubuntu 22.04 now, Wifi is deactivated, the Raspi is connected with a cable to the EX6150, so Internet must be routed via the extender.

Browsing works,
I can ping another openwrt C7

ping -c1
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=6.74 ms

But I cannot connect via ssh to the C7:

ssh root@
Unable to negotiate with port 22: no matching host key type found.
Their offer: ssh-rsa

Edit: solved my ssh-connection problem.

Fixed by adding PubkeyAcceptedKeyTypes to my .ssh/config

HostKeyAlgorithms ssh-rsa
PubkeyAcceptedKeyTypes ssh-rsa

I tried to connect to the C7 to compare /etc/config/wireless

With my mobile phone the access point "PaE4" is not shown

When I browse with this configuration, I can access to the C7 and see what Luci says.

The big difference with the extender is:
Wireless is not associated

Looks like this line was missing:

option mode 'ap'

My newest wireless config, which seems to work.
Please check if you find a problem with the configuration.

cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/a000000.wifi'
	option band '2g'
	option htmode 'HT20'
	option channel '11'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'PaE4'
	option encryption 'psk2'
	option key 'password'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/a800000.wifi'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option ssid 'PaW4'
	option encryption 'psk2'
	option key 'password'
	option mode 'sta'
	option bssid 'CC:...:CA'
	option wds '1'
	option network 'lan'

At the moment I cannot test dhcp, since I use static addresses most times.

There are some minor issues.


The router led blinks green. According to the manual there are colors and no blinking for a bad signal.

The power led is green and all other LEDs are off

Luci shows for the extender:
---/-101 dBm

-57/-101 dBm

my phone shows -64dBm
option txpower '10' as a worst case, sometimes it is -39dB, depending if the dvb-enigma-box is on, which is 20cm away from the extender. But speed is ok, I stream 4k-movies via Wifi.

I reduced it, because it was so strong, when testing with the mobile phone. It blinked before setting to 10 too. After installation it was at maximum.

The master shows -62dBm at the mobile phone.

Would you recommend other settings? How can I stop permanent blinking?