Setting up IPv6 6rd

Hello. Does anyone know how to setup 6rd through LuCI? No commands. The IPv6 6rd settings are for centurylink.

Several tutorials for other routers on the Internet seem use the following settings which you can try.

Remote IPv4
IPv6 prefix 2602::
IPv6 prefix length 24
IPv4 prefix length 0

You need And it seems you need to select another protocol when adding the interface. And then switch to 6rd.

1 Like

Should I set this via WAN6?

Yes you should be able to switch wan6 to the 6rd protocol.

I set it as that and it says no connectivity on WAN6.

What's your relay server?

Please provide information needed to assist you.

1 Like

Hello, I am having trouble setting up ipv6 as well (from LuCI). I found this thread from searching "openwrt centurylink ipv6", so hopefully I can get help here- let me know if I should make my own thread.

Router: GL-AX1800 (gl-inet router)
OpenWrt version: Chaos Calmer 15.05.1 a828782+r49254
Kernel: 4.4.60

The setup I am currently using: I have my openwrt router set up providing dhcp/dns etc., hooked into my DSL modem provided by my ISP (centurylink). The modem is in transparent bridging mode, with nearly every other setting disabled (aside from NAT- is this an issue?). The router is providing a WAN connection over PPPoE, and it's working fine, but only over ipv4.

After I tried the instructions @mikma gave, it did actually populate the lan, guest network, & wan with ipv6 addresses on the "interfaces" page. However I've tried accessing ipv6 addresses over the internet, and gotten no results- I did a ping from the router as well, and got nothing.

Any help would be greatly appreciated, thank you :slightly_smiling_face:

Ask GL.Inet, it's their version/fork of openwrt...

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.