Setting up IPTV with DSA on OpenWrt 21.02

I've installed OpenWRT 21.02 on my WRT1900ACS router and have problems setting up IPTV. On this newer version of OpenWRT there is no "Switch" menu in luci and I've been trying to setup a properly working configuration but fail every time. I need my lan port 4 to be untagged on vlan id 6, but every time I try to set it up I face either one of the two problems:

  1. IPTV on VLAN6 starts working but the rest of the lan switches and wifi suddenly has no internet connection
  2. No internet at all - config changes get automatically reverted.

The closest I got to my goal was when I added "wan" port to br-lan device bridge ports, enabled vlan filtering and added VLAN 6 with LAN4 port untagged and WAN port tagged, however I faced the first problem - iptv works, internet and wifi for all other devices don't, changes get reverted.

Has someone faced a similar problem and could please lend a hand? I'm beginning to lose hope:(

Yes you're on the right track to do that. Also add another numbered VLAN (like 1) for the LAN network, make it untagged on the ports that will have LAN PCs (lan1 lan2 lan3) and connect to the lan network interface with br-lan.1 instead of just br-lan.

If you start up a wifi AP and log in by wifi you won't lose contact when something is wrong with the Ethernet.

Thanks for the quick answer! I've added another VLAN 1 as per your instructions and specified the "Device" of "br-lan" interface to be "br-lan.1".

The internet still seems to be not working. However, the settings now did not get reverted and for a split-second it seemed like everything was about to work... The only difference I've noticed is that now I could still access the luci gui from my PC. I ran a troubleshoot on my network & internet settings in Windows which at first told me "Windows cant communicate with the device primary DNS" and repeating it then resulted in "Your DNS server might be unavailable".

It feels like a step forward, but not yet there. What else can I try at this point?

I forgot that you'll also need to hook up the wan through a vlan. Create a vlan 2, local box checked, untagged on the wan port, and use br-lan.2 as the wan physical device.

It ends up being exactly like swconfig, but the kernel people are happier with it.

I think you can uncheck 'local' on the TV VLAN, since the router CPU need not process any packets for it, but save that until after everything else is working.

Still the same problem after establishing vlan 2. While the settings are being saved and applied the tv starts working, the internet/wifi for pc don't. Settings get reverted back after 90s. Running "Diagnose" on ethernet adapter gives "Ethernet doesn't have a valid IP configuration". Here's my current setup:



Device for wan should be br-lan.2 and device for lan should be br-lan.1. It's strange that is chosen in the pull down box but the summary at the top shows something different.

Again, log in by wifi so you don't get reverted.

The summary is different because I'm locked to a pop-up of "applying changes" and they get reverted afterwards. I've tried setting up a WiFi AP by following the main guide for 21.02 - https://openwrt.org/docs/guide-user/network/wifi/dumbap, but I'm unable to pass step 6 where I need to establish 192.168.1.1 as my gateway since it's giving me an error "The gateway address must not be a local IP address". Regardless of the wifi login, the changes only get reverted after 90secs which is plenty of time for the internet to pick up connection, but it never does.

As I see, lan1 is not used. Remove it from the bridge and create a new “management” interface assigned to lan1 with a static IP address of your choice (it could be even a free address in the 192.168.1.x range). Connect some PC (with a static IP) to lan1 and login into the router using the newly created IP. Apply the changes and they won’t be reverted.

The problem isn't that the changes are reverted but rather that IPTV starts working while internet/wifi for other devices stops working and don't ever recover

No don't configure the whole box as a dumb AP, just turn on a wifi radio on lan-- which is already in the default configuration but disabled for security (otherwise your neighbors would have an open wifi at first boot)

Go to the network-wireless page and edit one of the APs -- set up encryption and probably change the SSID from 'OpenWrt'. Also at the top of the page click the Advanced tab and set your country. Then click Enable and it should come on the air.

I think I have a little trouble understanding this part, but I think I had the wifi part setup done beforehand. By default I could only click edit on 2 aps both of which are currenty enabled, encrypted and set to my country in advanced tab.