Setting up FRITZ 7520 unofficial version with DSL

Hi all.

Im new to OpenWrt and have set up the firmware on the 7520 with DSL. The DSL seems to work fine, though the speed is 180 Mbps, not quite the 250 from the ISP Deutsche Telekom. There are also some Non Pre-emptive CRC errors (CRC_P) errors. Are these things normal?

I also can't seem to get the network config to work. Wifi Devices have no internet even though connected to the wifi, only LAN devices have internet. But all devices can be seen in Luci, they are in the list.

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd0d:197a:db5a::/48'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option annex 'b'
        option tone 'bv'
        option xfer_mode 'ptm'
        option line_mode 'vdsl'
        option ds_snr_offset '0'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'dsl0'
        option macaddr 'xxx'
        option ipv6 '0'

config device
        option name 'dsl0.7'
        option ifname 'dsl0'
        option type '8021q'
        option vid '7'

config interface 'wan'
        option device 'dsl0.7'
        option proto 'pppoe'
        option username 'xxx'
        option password 'xxx'
        option peerdns '0'
        option ipv6 '0'

Thanks to all.

If the device works, let it run for about a week before looking closer at the last bits of performance, the other side of your VDSL connection (the DSLAM) treats modem restarts as problems with the connection and lowers throughput (keyword DLM := Dynamic Line Management and ASSIA := Adaptive Spectrum and Signal Alignment) to improve stability.

While I still was on VDSL/ DTAG, updating the modem firmware (so that single reboot/ connection loss) usually cost me ~15-20% performance degradation (on a non-OpenWrt Draytek Vigor 130b), before it crept back up to full speed after several days of uninterrupted operations.

2 Likes

Please do not post twice in different threads, even if you add a note - this leads to a lot of confusion.

@tmomas Could you please delete this thread and move @slh's post to the other thread (or the other way round, whatever you see fit): Adding support for VRX518 (and maybe VRX320)

2 Likes

We need to see your wireless configuration for (/etc/config/wireless) for diagnosing this, but just a guess: Did you assign your WiFi interface to the correct network (i.e. lan)?

It seems that I was wrong. Only LAN1 works. Other connected devices via LAN2 or any other don't work as well.

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/a000000.wifi'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option key 'xxx'
        option ssid 'xxx'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/a800000.wifi'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option key 'xxx'
        option ssid 'xxx'

And here are the firewall settings.

config defaults
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option input 'REJECT'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'