I have OpenWrt on a raspberry pi4 working as a basic router. I was able to follow the guide to make it work where the cable modem is attached to the built-in eth0 and the wireless radio0 is providing wifi just fine. I have a dongle with an ethernet port installed and working as eth1 - just trying to figure out the steps to make it into a working lan port where I could plug a device into that to serve internet at the same time as the wifi is serving internet to wireless devices. wan lan firewall interfaces devices - it's all a mysterious maze to me. My best guesses for this simple task have not worked.
Just add eth1
to the br-lan
(bridge) device.
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth1'
config interface 'lan'
option device 'br-lan'
...
This is my entry now. Can I have two ‘lan’ entries? Or combine everything somehow?
config interface 'lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option device 'wlan0'
remove device 'wlan0'
and make it device 'br-lan'
Thanks. It's working!
This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.