Setting up a dumb AP on a snapshot install EA8100v2 device fails

A few problems here with this Linksys EA8100 v2 have led me down this path.

A) the snapshot has no LUCI installed, which is suboptimal. But can only install once the router has net access
B) hooking the router behind the existing modem/router combo device at 1.1 makes the device unreachable (after changing the EA8100 ip address to 1.254, or anything on that range for the matter).
C) Maybe some additional settings are necessary for this, but the moment I set up the /etc/config/network config to add the suggested settings for a dumb AP, the LAN ports immediately shut off and I'm locked out of the device and need a reset.

Made these following adjustments:

config interface lan
        option ifname 'eth0' #newly added
        option type 'bridge' #newly added
        option proto 'static'
        option ipaddr '192.168.1.254' #adjusted
        option netmask '255.255.255.0'
        option gateway '192.168.1.1' #newly added
        option dns '192.168.1.1' #newly added

I've done testing that the moment the option type 'bridge' is added, this is what kills all the ports.

D) I'd use CLI to add in the PPPoE details and configure the router as is, moving the existing router/modem to bridge mode, however I wont have access to that device for a while, so I'd rather have this AP running the wifi for the time being.

Any clue what to do with this?

It applies to all IPs in that subnet, if connected LAN<>WAN, instead of LAN<>LAN.

I assume you've seen https://openwrt.org/docs/guide-user/network/wifi/dumbap ?

1 Like

this is what I use on V21 it work on master a few mouths ago as well
reset you openwrt
run this in ssh

uci add_list network.cfg030f15.ports=$(uci get network.wan.device)
uci del network.wan

uci set network.lan.proto="dhcp"
uci del network.lan.ipaddr
uci del network.lan.netmask
uci del network.lan.ip6assign
uci set network.lan.delegate='0'

uci del network.wan6
uci set network.lan6=interface
uci set network.lan6.proto='dhcpv6'
uci set network.lan6.device='@lan'
uci set network.lan6.reqaddress='try'
uci set network.lan6.reqprefix='no'
uci commit network

uci del firewall.cfg02dc81.network
uci set firewall.cfg02dc81.network='lan lan6'
uci commit firewall

/etc/init.d/dnsmasq disable
/etc/init.d/dnsmasq stop

uci del dhcp.lan
uci del dhcp.wan
uci del dhcp.odhcpd
uci set dhcp.lan=dhcp
uci set dhcp.lan.interface='lan'
uci set dhcp.lan.ignore='1'
uci add_list dhcp.lan.ra_flags='none'
uci commit dhcp

/etc/init.d/odhcpd disable
/etc/init.d/odhcpd stop

and install luci

opkg update
opkg install luci

it will get it's ip from you main router & then setup wifi etc

not connected to WAN obviously.

Yes Ive seen that, which is why the problem has me stumped. Ive done it with other devices many times

OK that seemed to kill the LAN ports again. Not sure which part is doing it exactly.

you will have to find what IP the DHCP server has given it
you can try & move the cable from your router to a lan port
if something went wrong with add wan interface to the lan
one you find it & the mac address it's using
you can add a static dhcp entry to your desired address in the router

Hi.
I'm running a R6220 on snapshot as an AP too, it is the same target (mt7621) than EA8100. So our config network files should be almost identical.

Here is the content of /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fd06:xxxxxxxxxxxxxxxx'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.1.2'
        list dns '192.168.1.1'
        option gateway '192.168.1.1'

Notice option device 'br-lan' and not 'bridge'
and no option ifname 'eth0'

Try these tiny changes, it may work.

I would recommend that you create your own custom build that includes Luci. Flash it without keeping the settings, wou will have a "clean" device at reboot. The network config file will be set accordingly to the new DSA syntax. Make a few modifications using Luci as described in the AP page.