Setting static routes and default routes for Ubiquiti RocketM2's

Hello :wave: new here,

I'm after some networking advice to successfully extend internet connectivity over a few ubiquiti rocket M2's using 802.11s mesh. I'd ideally like to create a single access point at the last rocket in the network for end-user-devices to connect to and successfully pull down internet.

Here's the details;

Model: Ubiquiti RocketM2 SWX-RM2W
Firmware: openwrt-19.07.9-ar71xx-generic-ubnt-loco-m-xw-squashfs-factory.bin
Packages: wpad-mesh-wolfssl, mesh11sd_1.2.0-3_all.ipk
Goal/Aim: Router (internet gateway) - - - > Rocket(1) - - - > Rocket (2) - - - > Rocket (3) [access point]

Here's the network details of the Rocket(1) that is directly connected to my internet gateway;

config interface 'loopback'

  •    option ifname 'lo'*
    
  •    option proto 'static'*
    
  •    option ipaddr '127.0.0.1'*
    
  •    option netmask '255.0.0.0'*
    

config globals 'globals'

  •    option ula_prefix 'fd75:3780:2e89::/48'*
    

config interface 'lan'

  •    option ifname 'eth0'*
    
  •    option proto 'static'*
    
  •    option ipaddr '192.168.2.1'*
    
  •    option netmask '255.255.255.0'*
    
  •    option ip6assign '60'*
    
  •    list dns '1.1.1.1'*
    

config interface 'wwan'

  •    option ipaddr '192.168.1.254'*
    
  •    option netmask '255.255.255.0'*
    
  •    option gateway '192.168.1.1'*
    
  •    list dns '1.1.1.1'*
    
  •    option proto 'static'*
    

config route

  •    option gateway '192.168.1.1'*
    
  •    option target '192.168.1.0/24'*
    
  •    option interface 'wwan'*
    
  •    option netmask '255.255.255.0'*
    

For the second and third rocket, do I need to just simply set a static route to rocket(1)? and update the dns entry?

I cant' seem to pull down internet from rocket(1) from that configuration either so any advice is welcome!

Thank you in advance for your help.

Firstly make sure you "sandwich" your text between two rows of backtick characters ` (which themselves will be invisible in the preview) looking in something like this in the editor:
```
Your Pasted Text as preformatted text with fixed width font
1
1111 (note with fixed-width fonts the numbers are right-aligned)
```
but looking like this in the rendered forum:

Your Pasted Text as preformatted text with fixed width font
   1
1111 (note with fixed-width fonts the numbers are right-aligned)

Second, your OpenWrt version 19 is very old and unsupported. It may as well be difficult to reproduce your issues.
Third, the route that you have is not needed, as the 192.168.1.0/24 is directly connected from interface wwan.
For the 2nd an3rd Rockets, it depends on whether the access point interface and the mesh interface will be bridged or routed. For the first, you don't need much, just the default gateway for the Rocket to access the internet. For the second you'd need static routes on the other rockets to know where to find the access point network of rocket 3.

1 Like

Gotcha, sorry for the messed up text.

I finally got around to re-investigating this recently and as it turns out, the solution is quite simple.

For each Rocket, I just need to keep everything connected over the 'lan' interface, it eats up addresses in the router's local network, but it keeps every rocket and access-point client connected over the same network, 'duh' to me.

Let's say the Router (gateway) is 192.168.1.1
First Rocket:
Interface='lan'
Static IP=192.168.1.254
Netmask=255.255.255.0
Gateway=192.168.1.1
Mesh ID=
Mesh Interface='lan'

Second Rocket (pretty much repeat this but select a separate static IP for each rocket):
Interface='lan'
Static IP=192.168.1.253
Netmask=255.255.255.0
Gateway=192.168.1.1
Static Route: target=0.0.0.0/0, mask=255.255.255.0, gateway=192.168.1.1
Mesh ID=
Mesh Interface='lan'

In the interface configuration for each rocket from the second onwards requires the check box 'ignore interface' to be checked at the DHCP settings tab.

Access point config is simply set on the last rocket, I had to disable and enable to activate it.

Other things I've noted which I'm sure is detailed somewhere;

  • Mesh ID needs to be the same on ALL participating Rockets in the mesh,
  • I'm not sure if this is necessary but I had to set the Wifi channel to the same frequency for all Rockets.

That's pretty much it, works for me and hopefully leaving this here helps another.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.