Setting applied in uci not appearing in luci

Hi there, sorry if this is a noob question.

This is a fresh install of OpenWRT 22.03 on a GL-AR300M (the NAND version, with the NAND build of OpenWRT).

From the command line, I did

uci set uhttpd.main.redirect_https='1'
uci commit uhttpd

I've since rebooted the device, and the change is still reflected in the output when I run uci show uhttpd | grep redirect

However, the corresponding checkbox is not checked in Luci.

Either I've done something wrong, or Luci is not reflecting reality for some reason. I'd like to figure it out in either case. Any hints would be appreciated.

There is a new syntax:

 uci set uhttpd.main.redirect_https='on'

However, the old syntax still seems to work as expected, but the changes are not being registered by LuCI...