Set OpenWrt to use Google DNS

I have current openwrt installed, and I've forgotten where/how to set the PC to use Google's DNS.

I have Verizon FIOS and have their router set in bridge mode.

Under Network, Interfaces, LAN, I have use custom DNS servers set to: 8.8.8.8, 8.8.4.4.

A bad request still comes back with a Verizon page telling me the page could not be found.

Suggestions to fix this?

Thanks

Andrew

https://openwrt.org/docs/guide-user/base-system/dhcp_configuration#upstream_dns_provider

Network > Interfaces > WAN, WAN6 > ...

3 Likes

I used these commands:

uci set network.wan.peerdns="0"
uci set network.wan.dns="8.8.8.8 8.8.4.4"
uci set network.wan6.peerdns="0"
uci set network.wan6.dns="2001:4860:4860::8888 2001:4860:4860::8844"
uci commit network
service network reload

I connected to the router, but had no internet access.

I changed the defaults back to use provided DNS, and no change. I'm now locked out of internet access. I can attached to the wifi on the Verizon router and connect (hence this post).

I made no other changes; how can I get internet access back? I have rebooted the openwrt router several times.

Andrew

  • System > Backup / Flash Firmware > Actions: Backup > Generate archive
  • System > Backup / Flash Firmware > Actions: Restore > Perform reset
1 Like

So yes, that destroys all my settings completely.

Restoring from the new archive recreates the problem (eg no internet).

Any way to recover without recreating all my settings from scratch? VPN, guest networks, port forwards, etc.

Andrew

uci show network; uci show firewall; uci show dhcp

I live in a weird world - and I'm obviously having a bad day.

I've reset the router - nothing I do gives me back internet access.
I have also plugged in my old router which also has openwrt - it too fails to give me internet access.

Setup:
Verizon FIOS Router in bridge mode
Openwrt router (Nighthawk or WNDR3700)
PC plugged directly in to Nighthawk/WNDR3700

With either of my routers plugged into the FIOS router, an internet page returns:
DNS_PROBE_FINISHED_NO_INTERNET

wireless connections tell me the network has no internet connection also.

I can connect to the router either by ssh or 192.168.1.1 and make changes to the router.
from the router (ssh) I can't ping any outside IP.

The FIOS router's control page doesn't show the router (either) as connected. Is there something wrong in my WAN setting (I'm stupid guessing) which is blocking/stopping the router from being seen as connected/trying to connect?

config interface 'wan'
     option ifname 'etho0.2'
     option proto 'dhcp'
     option clientid 'root'
config option 'lan'
     option type 'bridge'
     option ifname 'eth1.1'
     option proto 'static'
     option netmask '255.255.255.0'
     option ip6assign '60'
     option ipaddr '192.168.40.1'

Any help would be greatly appreciated.

Andrew

Remove it:

uci delete network.wan.clientid
uci commit network
service network restart
traceroute example.org
traceroute6 example.org

Is that a typo?

...a G1100 in bridge mode???

Are you sure your Verizon router isn't a router and using 192.168.1.0/24 also?

  • WHY DOES THIS KEEP APPEARING IN PEOPLE'S CONFIGS!?!?!?
  • Do you know why you have this; and is it required???

OK...totally lost now, your router IP is 192.168.40.1, not 1.1.

Good catch!

Likely form auto fill in LuCI.

1 Like