Set MAC to activate wireless on Actiontec GT784WNV

The OpenWRT wiki page for Actiontec GT784WNV says:

The MAC address is initialized to all zeroes, which prevents normal config. It can be set manually, after which wireless works.

I'm not sure where to set the wifi hardware address. After installing, no /etc/config/wireless exists, and there's no wireless interface in /etc/config/network.

Which version are you using?

Try the new 18.06
Or trunk/master

Thanks for the suggestion.

I was using version 17.01.4. I installed kmod-brcmsmac and that created the /etc/config/wireless file on reboot. I also tried kmod-b43 with no luck. I just get a "Wireless disabled or not associated" message, when it is enabled.

I tried with 18.06 and trunk using the links you gave and this procedure:

  1. Flash 18.06 on device
  2. Update package lists
  3. Install kmod-brcmsmac and reboot
  4. Disable and reenable wifi in N and G (legacy) modes
  5. Uninstall kmod-brcmsmac, install kmod-b43, reboot
  6. Delete /etc/config/wireless and run wifi config
  7. Flash trunk version on device
  8. Install luci
  9. Repeat steps 2-7

All I ever got was "Wireless is disabled or not associated".

Some people claimed to have luck with a patched firmware version found on a thread, but I couldn't find a copy of it. (I was hoping that patch's magic would be incorporated in the newer OpenWRT versions.)

It seems like broadcom is a generally unpopular chip for linux drivers. I remember having trouble with a broadcom chip while installing ubuntu on a laptop about ten years ago.

I'm going to put this box on the shelf and try my luck with a netgear WPN824N in my junk pile, which has an aethos chip. I'd be happy to pull the actiontec off the shelf if anyone has any other suggestions I should try though.

You should be aware of this:

By some miracle, the Actiontec is now working. Here's what I did:

  1. Flash 18.06 on the box without importing any settings
  2. Setup password and internet access
  3. Update package lists
  4. Install wpad and kmod-brcmsmac (in that order)
  5. Reboot
  6. Enable wifi

I never ran wifi config but presumably it ran on reboot. The only major difference I could spot is that I installed wpad before /etc/config/wireless got created... maybe it was a required dependency.

For the record, the working config has it operating in N mode on channel 11. I set it up for WPA2-PSK and set the country from 00 to US and it's still working fine. Here's the full working /etc/config/wireless, if it helps anyone:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0/bcma0:1'
        option htmode 'HT20'
        option legacy_rates '1'
        option country 'US'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'keithnet'
        option encryption 'psk2'
        option key 'REDACTED'
        option wpa_disable_eapol_key_retries '1'
        option network 'lan'

This likely fixed the issue.

@keith24 you could report this working to so they could configure this when the snapshots get produced and feature releases.

Oh, I didn't open a bug report. I don't think they have to configure anything since it finally worked using the original 18.06 settings. I just had to install wpad and kmod-brcmsmac.

Haven't tried it with snapshot and I probably won't since it's already working.

1 Like

A post was split to a new topic: OpenWrt installation on Actiontec GT784WNV