Services tab missing on FritzBox!4040 / 19.07.2

Hi guys,

I've been using OpemWRT for years with absolutely not problems. Last week, there was an update to dnsmasq-full which broke DNS. The release notes seems mundane but oh well - got that fixed by reverting to a previous version. I might be wrong about this though.

Sadly though. the services menu tab seemed to have disappeared (the only to additional packages I run are OpenSSL and SSL policy based routing with their dependencies). I've tried everything to get them back including the nuclear option of a full factory reset (i.e. FTP via adam2) to install OpenWRT with zero config then just install the 2 packages again along with the standard dependencies. Still no luck.

Any ideas?


Normally, removing /tmp/luci* or rebooting fixes this kind of problems, a full reinstall is not needed.

In my hacking prior to the rebuild, I think i tried this. I've just given it another try by no luck.

One thing I do notice is that the initial loading has a 'refreshing' notification in the top right for a few minutes implying it is still trying to do something but never succeeds. Do you know of any log files which might give a clue as to what it is up to?

Hmm, nope, my knowledge of LUCI is pretty limited.

Could it be that you changed the router address and your browser is stalling? Or perhaps the DHCP configuration is broken and you're not getting a new lease? Anyhow, a full reset should definitely give you back a working unit, there's something that doesn't add up.

The odd thing is its all sort of fine. I'm definately getting an IP and most aspects seem to be working. It's just the LUCI-APP bits which seem to be failing.

Sorry, I don't think anything can survive a full reflash, especially if you do not reinstall extra packages and you do not restore configs wholesale. I'd suggest that you try again: no need to reflash, simply do a soft reset

The reflash was the nuclear option, just in case I was missing something in the soft reboot. I've convinced myself its something in either openvpn or policy based routing.

Fingers crossed, something will occur to me.

1 Like

The services menu only shows up when there are relevant packages installed along with the luci-app-* components.

For example, on my device: dynamic dns (ddns), shadowsocks-libev, and wake on lan.

If you reset to defaults or flashed a fresh image, those packages will almost certainly need to be reinstallled.

1 Like

I found the problem and solution.

I'm not sure vpn-policy-routing itself is to blame. More likely a dependency.

Good catch!

Perhaps you might consider editing the thread title, too.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.