[Solved] Server returned IA_PD status 'Not On Link (This address is not on link)'

root@Router:~# tcpdump -vv | grep dhcp6
tcpdump: listening on br-lan, link-type EN10MB (Ethernet), capture size 262144 bytes
296 packets captured
310 packets received by filter
0 packets dropped by kernel

It is apparently listening on lan (eth0.20) must this not be wan (eth0.10)?

tcpdump -evni eth0.10 udp port 547 & \
sleep 5; \
killall -SIGUSR1 odhcp6c; \
sleep 5; \
killall tcpdump

thx, whas tying to figure it out.. :wink:

here is the tcpdump

usyBox v1.33.2 (2022-08-28 06:33:46 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 21.02.3, r16554-1d4dea6d4f
 -----------------------------------------------------
root@Router:~# tcpdump -evni eth0.10 udp port 547 & \
> sleep 5; \
> killall -SIGUSR1 odhcp6c; \
> sleep 5; \
> killall tcpdump
tcpdump: listening on eth0.10, link-type EN10MB (Ethernet), capture size 262144 bytes
11:13:46.248629 dc:a6:32:9e:b7:80 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 236: (flowlabel 0x2498c, hlim 1, next-header UDP (17) payload length: 182) fe80::dea6:32ff:fe9e:b780.546 > ff02::1:2.547: [udp sum ok] dhcp6 request (xid=1e3b5e (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96) (client-ID hwaddr type 1 dca6329eb780) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257)) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800)))
11:13:46.270273 ac:f8:cc:8f:9e:fa > dc:a6:32:9e:b7:80, ethertype IPv6 (0x86dd), length 408: (flowlabel 0x5b463, hlim 64, next-header UDP (17) payload length: 354) fe80::aef8:ccff:fe8f:9efa.547 > fe80::dea6:32ff:fe9e:b780.546: [udp sum ok] dhcp6 reply (xid=1e3b5e (IA_NA IAID:1 T1:302128 T2:483405 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257) (status-code Success)) (IA_PD IAID:1 T1:5 T2:10 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code Success)) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code NotOnLink)) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (client-ID hwaddr type 1 dca6329eb780) (preference 255) (DNS-server 2001:b88:1002::10 2001:b88:1202::10 2001:730:3e42:1000::53) (authentication proto: reconfigure, alg: HMAC-MD5, RDM: mono, RD: 0000 0000 0000 0000 reconfig-key value: feb08e49 e7da8303 c8cb4c05 9c5c4774))
11:13:46.913756 dc:a6:32:9e:b7:80 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 163: (flowlabel 0x2498c, hlim 1, next-header UDP (17) payload length: 109) fe80::dea6:32ff:fe9e:b780.546 > ff02::1:2.547: [udp sum ok] dhcp6 solicit (xid=22b9a5 (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96 opt_82) (client-ID hwaddr type 1 dca6329eb780) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0) (IA_PD IAID:1 T1:0 T2:0))
11:13:46.918672 ac:f8:cc:8f:9e:fa > dc:a6:32:9e:b7:80, ethertype IPv6 (0x86dd), length 345: (flowlabel 0x5b463, hlim 64, next-header UDP (17) payload length: 291) fe80::aef8:ccff:fe8f:9efa.547 > fe80::dea6:32ff:fe9e:b780.546: [udp sum ok] dhcp6 advertise (xid=22b9a5 (IA_NA IAID:1 T1:302128 T2:483405 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257) (status-code Success)) (IA_PD IAID:1 T1:5 T2:10 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code Success)) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (client-ID hwaddr type 1 dca6329eb780) (preference 255) (DNS-server 2001:b88:1002::10 2001:b88:1202::10 2001:730:3e42:1000::53))
11:13:47.843224 dc:a6:32:9e:b7:80 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 236: (flowlabel 0x2498c, hlim 1, next-header UDP (17) payload length: 182) fe80::dea6:32ff:fe9e:b780.546 > ff02::1:2.547: [udp sum ok] dhcp6 request (xid=f29be8 (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96) (client-ID hwaddr type 1 dca6329eb780) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257)) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800)))
11:13:47.864876 ac:f8:cc:8f:9e:fa > dc:a6:32:9e:b7:80, ethertype IPv6 (0x86dd), length 408: (flowlabel 0x5b463, hlim 64, next-header UDP (17) payload length: 354) fe80::aef8:ccff:fe8f:9efa.547 > fe80::dea6:32ff:fe9e:b780.546: [udp sum ok] dhcp6 reply (xid=f29be8 (IA_NA IAID:1 T1:302128 T2:483405 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257) (status-code Success)) (IA_PD IAID:1 T1:5 T2:10 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code Success)) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code NotOnLink)) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (client-ID hwaddr type 1 dca6329eb780) (preference 255) (DNS-server 2001:b88:1002::10 2001:b88:1202::10 2001:730:3e42:1000::53) (authentication proto: reconfigure, alg: HMAC-MD5, RDM: mono, RD: 0000 0000 0000 0000 reconfig-key value: 87631ba9 6628b20e 6d936e70 ab28c08e))
11:13:48.314325 dc:a6:32:9e:b7:80 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 163: (flowlabel 0x2498c, hlim 1, next-header UDP (17) payload length: 109) fe80::dea6:32ff:fe9e:b780.546 > ff02::1:2.547: [udp sum ok] dhcp6 solicit (xid=7036f9 (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96 opt_82) (client-ID hwaddr type 1 dca6329eb780) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0) (IA_PD IAID:1 T1:0 T2:0))
11:13:48.319629 ac:f8:cc:8f:9e:fa > dc:a6:32:9e:b7:80, ethertype IPv6 (0x86dd), length 345: (flowlabel 0x5b463, hlim 64, next-header UDP (17) payload length: 291) fe80::aef8:ccff:fe8f:9efa.547 > fe80::dea6:32ff:fe9e:b780.546: [udp sum ok] dhcp6 advertise (xid=7036f9 (IA_NA IAID:1 T1:302128 T2:483405 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257) (status-code Success)) (IA_PD IAID:1 T1:5 T2:10 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code Success)) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (client-ID hwaddr type 1 dca6329eb780) (preference 255) (DNS-server 2001:b88:1002::10 2001:b88:1202::10 2001:730:3e42:1000::53))
11:13:49.011120 dc:a6:32:9e:b7:80 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 236: (flowlabel 0x2498c, hlim 1, next-header UDP (17) payload length: 182) fe80::dea6:32ff:fe9e:b780.546 > ff02::1:2.547: [udp sum ok] dhcp6 request (xid=d2c066 (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96) (client-ID hwaddr type 1 dca6329eb780) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257)) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800)))
11:13:49.031639 ac:f8:cc:8f:9e:fa > dc:a6:32:9e:b7:80, ethertype IPv6 (0x86dd), length 408: (flowlabel 0x5b463, hlim 64, next-header UDP (17) payload length: 354) fe80::aef8:ccff:fe8f:9efa.547 > fe80::dea6:32ff:fe9e:b780.546: [udp sum ok] dhcp6 reply (xid=d2c066 (IA_NA IAID:1 T1:302128 T2:483405 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257) (status-code Success)) (IA_PD IAID:1 T1:5 T2:10 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code Success)) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code NotOnLink)) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (client-ID hwaddr type 1 dca6329eb780) (preference 255) (DNS-server 2001:b88:1002::10 2001:b88:1202::10 2001:730:3e42:1000::53) (authentication proto: reconfigure, alg: HMAC-MD5, RDM: mono, RD: 0000 0000 0000 0000 reconfig-key value: f3a7e1fc 5b57378c 426a8318 633b89ae))
11:13:49.979058 dc:a6:32:9e:b7:80 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 163: (flowlabel 0x2498c, hlim 1, next-header UDP (17) payload length: 109) fe80::dea6:32ff:fe9e:b780.546 > ff02::1:2.547: [udp sum ok] dhcp6 solicit (xid=c07973 (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96 opt_82) (client-ID hwaddr type 1 dca6329eb780) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0) (IA_PD IAID:1 T1:0 T2:0))
11:13:49.984515 ac:f8:cc:8f:9e:fa > dc:a6:32:9e:b7:80, ethertype IPv6 (0x86dd), length 345: (flowlabel 0x5b463, hlim 64, next-header UDP (17) payload length: 291) fe80::aef8:ccff:fe8f:9efa.547 > fe80::dea6:32ff:fe9e:b780.546: [udp sum ok] dhcp6 advertise (xid=c07973 (IA_NA IAID:1 T1:302128 T2:483405 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257) (status-code Success)) (IA_PD IAID:1 T1:5 T2:10 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code Success)) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (client-ID hwaddr type 1 dca6329eb780) (preference 255) (DNS-server 2001:b88:1002::10 2001:b88:1202::10 2001:730:3e42:1000::53))
11:13:50.060836 dc:a6:32:9e:b7:80 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 236: (flowlabel 0x2498c, hlim 1, next-header UDP (17) payload length: 182) fe80::dea6:32ff:fe9e:b780.546 > ff02::1:2.547: [udp sum ok] dhcp6 request (xid=5b2d8e (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96) (client-ID hwaddr type 1 dca6329eb780) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257)) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800)))
11:13:50.084876 ac:f8:cc:8f:9e:fa > dc:a6:32:9e:b7:80, ethertype IPv6 (0x86dd), length 408: (flowlabel 0x5b463, hlim 64, next-header UDP (17) payload length: 354) fe80::aef8:ccff:fe8f:9efa.547 > fe80::dea6:32ff:fe9e:b780.546: [udp sum ok] dhcp6 reply (xid=5b2d8e (IA_NA IAID:1 T1:302128 T2:483405 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257) (status-code Success)) (IA_PD IAID:1 T1:5 T2:10 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code Success)) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code NotOnLink)) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (client-ID hwaddr type 1 dca6329eb780) (preference 255) (DNS-server 2001:b88:1002::10 2001:b88:1202::10 2001:730:3e42:1000::53) (authentication proto: reconfigure, alg: HMAC-MD5, RDM: mono, RD: 0000 0000 0000 0000 reconfig-key value: ceb50fad a1bfaf30 25a28a3d 6af01210))
11:13:50.630284 dc:a6:32:9e:b7:80 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 163: (flowlabel 0x2498c, hlim 1, next-header UDP (17) payload length: 109) fe80::dea6:32ff:fe9e:b780.546 > ff02::1:2.547: [udp sum ok] dhcp6 solicit (xid=bf99e0 (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96 opt_82) (client-ID hwaddr type 1 dca6329eb780) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0) (IA_PD IAID:1 T1:0 T2:0))
11:13:50.635710 ac:f8:cc:8f:9e:fa > dc:a6:32:9e:b7:80, ethertype IPv6 (0x86dd), length 345: (flowlabel 0x5b463, hlim 64, next-header UDP (17) payload length: 291) fe80::aef8:ccff:fe8f:9efa.547 > fe80::dea6:32ff:fe9e:b780.546: [udp sum ok] dhcp6 advertise (xid=bf99e0 (IA_NA IAID:1 T1:302128 T2:483405 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257) (status-code Success)) (IA_PD IAID:1 T1:5 T2:10 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code Success)) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (client-ID hwaddr type 1 dca6329eb780) (preference 255) (DNS-server 2001:b88:1002::10 2001:b88:1202::10 2001:730:3e42:1000::53))
11:13:50.747049 dc:a6:32:9e:b7:80 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 236: (flowlabel 0x2498c, hlim 1, next-header UDP (17) payload length: 182) fe80::dea6:32ff:fe9e:b780.546 > ff02::1:2.547: [udp sum ok] dhcp6 request (xid=c3e04c (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96) (client-ID hwaddr type 1 dca6329eb780) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257)) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800)))
11:13:50.769131 ac:f8:cc:8f:9e:fa > dc:a6:32:9e:b7:80, ethertype IPv6 (0x86dd), length 408: (flowlabel 0x5b463, hlim 64, next-header UDP (17) payload length: 354) fe80::aef8:ccff:fe8f:9efa.547 > fe80::dea6:32ff:fe9e:b780.546: [udp sum ok] dhcp6 reply (xid=c3e04c (IA_NA IAID:1 T1:302128 T2:483405 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257) (status-code Success)) (IA_PD IAID:1 T1:5 T2:10 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code Success)) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code NotOnLink)) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (client-ID hwaddr type 1 dca6329eb780) (preference 255) (DNS-server 2001:b88:1002::10 2001:b88:1202::10 2001:730:3e42:1000::53) (authentication proto: reconfigure, alg: HMAC-MD5, RDM: mono, RD: 0000 0000 0000 0000 reconfig-key value: c14f987f 5adde0a8 74c0c561 bd047900))
11:13:50.818661 dc:a6:32:9e:b7:80 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 163: (flowlabel 0x2498c, hlim 1, next-header UDP (17) payload length: 109) fe80::dea6:32ff:fe9e:b780.546 > ff02::1:2.547: [udp sum ok] dhcp6 solicit (xid=57c6f0 (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96 opt_82) (client-ID hwaddr type 1 dca6329eb780) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0) (IA_PD IAID:1 T1:0 T2:0))
11:13:50.824869 ac:f8:cc:8f:9e:fa > dc:a6:32:9e:b7:80, ethertype IPv6 (0x86dd), length 345: (flowlabel 0x5b463, hlim 64, next-header UDP (17) payload length: 291) fe80::aef8:ccff:fe8f:9efa.547 > fe80::dea6:32ff:fe9e:b780.546: [udp sum ok] dhcp6 advertise (xid=57c6f0 (IA_NA IAID:1 T1:302128 T2:483405 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257) (status-code Success)) (IA_PD IAID:1 T1:5 T2:10 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code Success)) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (client-ID hwaddr type 1 dca6329eb780) (preference 255) (DNS-server 2001:b88:1002::10 2001:b88:1202::10 2001:730:3e42:1000::53))
11:13:51.412584 dc:a6:32:9e:b7:80 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 236: (flowlabel 0x2498c, hlim 1, next-header UDP (17) payload length: 182) fe80::dea6:32ff:fe9e:b780.546 > ff02::1:2.547: [udp sum ok] dhcp6 request (xid=f408ce (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96) (client-ID hwaddr type 1 dca6329eb780) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257)) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800)))
11:13:51.434033 ac:f8:cc:8f:9e:fa > dc:a6:32:9e:b7:80, ethertype IPv6 (0x86dd), length 408: (flowlabel 0x5b463, hlim 64, next-header UDP (17) payload length: 354) fe80::aef8:ccff:fe8f:9efa.547 > fe80::dea6:32ff:fe9e:b780.546: [udp sum ok] dhcp6 reply (xid=f408ce (IA_NA IAID:1 T1:302128 T2:483405 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257) (status-code Success)) (IA_PD IAID:1 T1:5 T2:10 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code Success)) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code NotOnLink)) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (client-ID hwaddr type 1 dca6329eb780) (preference 255) (DNS-server 2001:b88:1002::10 2001:b88:1202::10 2001:730:3e42:1000::53) (authentication proto: reconfigure, alg: HMAC-MD5, RDM: mono, RD: 0000 0000 0000 0000 reconfig-key value: 637e278e b66876e4 77e55500 29e9776a))
11:13:51.869816 dc:a6:32:9e:b7:80 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 163: (flowlabel 0x2498c, hlim 1, next-header UDP (17) payload length: 109) fe80::dea6:32ff:fe9e:b780.546 > ff02::1:2.547: [udp sum ok] dhcp6 solicit (xid=bb246e (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96 opt_82) (client-ID hwaddr type 1 dca6329eb780) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0) (IA_PD IAID:1 T1:0 T2:0))
11:13:51.875534 ac:f8:cc:8f:9e:fa > dc:a6:32:9e:b7:80, ethertype IPv6 (0x86dd), length 345: (flowlabel 0x5b463, hlim 64, next-header UDP (17) payload length: 291) fe80::aef8:ccff:fe8f:9efa.547 > fe80::dea6:32ff:fe9e:b780.546: [udp sum ok] dhcp6 advertise (xid=bb246e (IA_NA IAID:1 T1:302128 T2:483405 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257) (status-code Success)) (IA_PD IAID:1 T1:5 T2:10 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code Success)) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (client-ID hwaddr type 1 dca6329eb780) (preference 255) (DNS-server 2001:b88:1002::10 2001:b88:1202::10 2001:730:3e42:1000::53))
11:13:51.878817 dc:a6:32:9e:b7:80 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 236: (flowlabel 0x2498c, hlim 1, next-header UDP (17) payload length: 182) fe80::dea6:32ff:fe9e:b780.546 > ff02::1:2.547: [udp sum ok] dhcp6 request (xid=390045 (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96) (client-ID hwaddr type 1 dca6329eb780) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257)) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800)))
11:13:51.897664 ac:f8:cc:8f:9e:fa > dc:a6:32:9e:b7:80, ethertype IPv6 (0x86dd), length 408: (flowlabel 0x5b463, hlim 64, next-header UDP (17) payload length: 354) fe80::aef8:ccff:fe8f:9efa.547 > fe80::dea6:32ff:fe9e:b780.546: [udp sum ok] dhcp6 reply (xid=390045 (IA_NA IAID:1 T1:302128 T2:483405 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257) (status-code Success)) (IA_PD IAID:1 T1:5 T2:10 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code Success)) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code NotOnLink)) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (client-ID hwaddr type 1 dca6329eb780) (preference 255) (DNS-server 2001:b88:1002::10 2001:b88:1202::10 2001:730:3e42:1000::53) (authentication proto: reconfigure, alg: HMAC-MD5, RDM: mono, RD: 0000 0000 0000 0000 reconfig-key value: 11f2ef4a a1d965a7 1295ae11 4dd68452))
11:13:52.735054 dc:a6:32:9e:b7:80 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 163: (flowlabel 0x2498c, hlim 1, next-header UDP (17) payload length: 109) fe80::dea6:32ff:fe9e:b780.546 > ff02::1:2.547: [udp sum ok] dhcp6 solicit (xid=23720e (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96 opt_82) (client-ID hwaddr type 1 dca6329eb780) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0) (IA_PD IAID:1 T1:0 T2:0))
11:13:52.738843 ac:f8:cc:8f:9e:fa > dc:a6:32:9e:b7:80, ethertype IPv6 (0x86dd), length 345: (flowlabel 0x5b463, hlim 64, next-header UDP (17) payload length: 291) fe80::aef8:ccff:fe8f:9efa.547 > fe80::dea6:32ff:fe9e:b780.546: [udp sum ok] dhcp6 advertise (xid=23720e (IA_NA IAID:1 T1:302128 T2:483405 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257) (status-code Success)) (IA_PD IAID:1 T1:5 T2:10 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code Success)) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (client-ID hwaddr type 1 dca6329eb780) (preference 255) (DNS-server 2001:b88:1002::10 2001:b88:1202::10 2001:730:3e42:1000::53))
11:13:52.847153 dc:a6:32:9e:b7:80 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 236: (flowlabel 0x2498c, hlim 1, next-header UDP (17) payload length: 182) fe80::dea6:32ff:fe9e:b780.546 > ff02::1:2.547: [udp sum ok] dhcp6 request (xid=dcef97 (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96) (client-ID hwaddr type 1 dca6329eb780) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257)) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800)))
11:13:52.868468 ac:f8:cc:8f:9e:fa > dc:a6:32:9e:b7:80, ethertype IPv6 (0x86dd), length 408: (flowlabel 0x5b463, hlim 64, next-header UDP (17) payload length: 354) fe80::aef8:ccff:fe8f:9efa.547 > fe80::dea6:32ff:fe9e:b780.546: [udp sum ok] dhcp6 reply (xid=dcef97 (IA_NA IAID:1 T1:302128 T2:483405 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257) (status-code Success)) (IA_PD IAID:1 T1:5 T2:10 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code Success)) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code NotOnLink)) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (client-ID hwaddr type 1 dca6329eb780) (preference 255) (DNS-server 2001:b88:1002::10 2001:b88:1202::10 2001:730:3e42:1000::53) (authentication proto: reconfigure, alg: HMAC-MD5, RDM: mono, RD: 0000 0000 0000 0000 reconfig-key value: 0817c466 25d5052a cc5693fe ee0111d2))
11:13:53.556898 dc:a6:32:9e:b7:80 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 163: (flowlabel 0x2498c, hlim 1, next-header UDP (17) payload length: 109) fe80::dea6:32ff:fe9e:b780.546 > ff02::1:2.547: [udp sum ok] dhcp6 solicit (xid=a9a342 (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96 opt_82) (client-ID hwaddr type 1 dca6329eb780) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0) (IA_PD IAID:1 T1:0 T2:0))
11:13:53.559424 ac:f8:cc:8f:9e:fa > dc:a6:32:9e:b7:80, ethertype IPv6 (0x86dd), length 345: (flowlabel 0x5b463, hlim 64, next-header UDP (17) payload length: 291) fe80::aef8:ccff:fe8f:9efa.547 > fe80::dea6:32ff:fe9e:b780.546: [udp sum ok] dhcp6 advertise (xid=a9a342 (IA_NA IAID:1 T1:302128 T2:483405 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257) (status-code Success)) (IA_PD IAID:1 T1:5 T2:10 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code Success)) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (client-ID hwaddr type 1 dca6329eb780) (preference 255) (DNS-server 2001:b88:1002::10 2001:b88:1202::10 2001:730:3e42:1000::53))
11:13:54.173975 dc:a6:32:9e:b7:80 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 236: (flowlabel 0x2498c, hlim 1, next-header UDP (17) payload length: 182) fe80::dea6:32ff:fe9e:b780.546 > ff02::1:2.547: [udp sum ok] dhcp6 request (xid=3ab64e (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96) (client-ID hwaddr type 1 dca6329eb780) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257)) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800)))
11:13:54.190569 ac:f8:cc:8f:9e:fa > dc:a6:32:9e:b7:80, ethertype IPv6 (0x86dd), length 408: (flowlabel 0x5b463, hlim 64, next-header UDP (17) payload length: 354) fe80::aef8:ccff:fe8f:9efa.547 > fe80::dea6:32ff:fe9e:b780.546: [udp sum ok] dhcp6 reply (xid=3ab64e (IA_NA IAID:1 T1:302128 T2:483405 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257) (status-code Success)) (IA_PD IAID:1 T1:5 T2:10 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code Success)) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code NotOnLink)) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (client-ID hwaddr type 1 dca6329eb780) (preference 255) (DNS-server 2001:b88:1002::10 2001:b88:1202::10 2001:730:3e42:1000::53) (authentication proto: reconfigure, alg: HMAC-MD5, RDM: mono, RD: 0000 0000 0000 0000 reconfig-key value: 22ba3a94 7152fa6e 2ff45613 189191f4))
11:13:54.459072 dc:a6:32:9e:b7:80 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 163: (flowlabel 0x2498c, hlim 1, next-header UDP (17) payload length: 109) fe80::dea6:32ff:fe9e:b780.546 > ff02::1:2.547: [udp sum ok] dhcp6 solicit (xid=191b77 (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96 opt_82) (client-ID hwaddr type 1 dca6329eb780) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0) (IA_PD IAID:1 T1:0 T2:0))
11:13:54.464288 ac:f8:cc:8f:9e:fa > dc:a6:32:9e:b7:80, ethertype IPv6 (0x86dd), length 345: (flowlabel 0x5b463, hlim 64, next-header UDP (17) payload length: 291) fe80::aef8:ccff:fe8f:9efa.547 > fe80::dea6:32ff:fe9e:b780.546: [udp sum ok] dhcp6 advertise (xid=191b77 (IA_NA IAID:1 T1:302128 T2:483405 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257) (status-code Success)) (IA_PD IAID:1 T1:5 T2:10 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code Success)) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (client-ID hwaddr type 1 dca6329eb780) (preference 255) (DNS-server 2001:b88:1002::10 2001:b88:1202::10 2001:730:3e42:1000::53))
11:13:55.295818 dc:a6:32:9e:b7:80 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 236: (flowlabel 0x2498c, hlim 1, next-header UDP (17) payload length: 182) fe80::dea6:32ff:fe9e:b780.546 > ff02::1:2.547: [udp sum ok] dhcp6 request (xid=3936f0 (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96) (client-ID hwaddr type 1 dca6329eb780) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257)) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800)))
11:13:55.312549 ac:f8:cc:8f:9e:fa > dc:a6:32:9e:b7:80, ethertype IPv6 (0x86dd), length 408: (flowlabel 0x5b463, hlim 64, next-header UDP (17) payload length: 354) fe80::aef8:ccff:fe8f:9efa.547 > fe80::dea6:32ff:fe9e:b780.546: [udp sum ok] dhcp6 reply (xid=3936f0 (IA_NA IAID:1 T1:302128 T2:483405 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257) (status-code Success)) (IA_PD IAID:1 T1:5 T2:10 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code Success)) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code NotOnLink)) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (client-ID hwaddr type 1 dca6329eb780) (preference 255) (DNS-server 2001:b88:1002::10 2001:b88:1202::10 2001:730:3e42:1000::53) (authentication proto: reconfigure, alg: HMAC-MD5, RDM: mono, RD: 0000 0000 0000 0000 reconfig-key value: 729927dd 46bca017 fc52527b 64db4557))
11:13:55.909481 dc:a6:32:9e:b7:80 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 163: (flowlabel 0x2498c, hlim 1, next-header UDP (17) payload length: 109) fe80::dea6:32ff:fe9e:b780.546 > ff02::1:2.547: [udp sum ok] dhcp6 solicit (xid=554034 (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96 opt_82) (client-ID hwaddr type 1 dca6329eb780) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0) (IA_PD IAID:1 T1:0 T2:0))
11:13:55.914558 ac:f8:cc:8f:9e:fa > dc:a6:32:9e:b7:80, ethertype IPv6 (0x86dd), length 345: (flowlabel 0x5b463, hlim 64, next-header UDP (17) payload length: 291) fe80::aef8:ccff:fe8f:9efa.547 > fe80::dea6:32ff:fe9e:b780.546: [udp sum ok] dhcp6 advertise (xid=554034 (IA_NA IAID:1 T1:302128 T2:483405 (IA_ADDR 2001:1c04:131e:6300::85 pltime:604257 vltime:604257) (status-code Success)) (IA_PD IAID:1 T1:5 T2:10 (IA_PD-prefix 2001:1c04:131e:6310::/60 pltime:86400 vltime:172800) (status-code Success)) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (client-ID hwaddr type 1 dca6329eb780) (preference 255) (DNS-server 2001:b88:1002::10 2001:b88:1202::10 2001:730:3e42:1000::53))

40 packets captured
40 packets received by filter
0 packets dropped by kernel
root@Router:~# 


The "not on link" is part of the dhcp reply you get, the second packet in the capture. For some reason the dhcp server is returning the same prefix twice. Also it has very low lease time, making dhcp client to keep asking for a renewal all the time.

The ISP modem/router tells me the leasetime is 604800 seconds. So can it be a fail of the ISP router?

Could it be hardware related maybe?

I could change my pi 4b with another one for the test?

I am referring to T1 and T2 intervals of 5 and 10 seconds, where the dhcp client must contact the dhcp server again. The leasetime is for the address OpenWrt gets from the upstream router.

I changed the hardware, another rp 4b. no error in the log anymore and the "mask": 128 is back again. But still no prefix.

root@Router:~# ifstatus wan6
{
	"up": true,
	"pending": false,
	"available": true,
	"autostart": true,
	"dynamic": false,
	"uptime": 1162,
	"l3_device": "eth0.10",
	"proto": "dhcpv6",
	"device": "eth0.10",
	"metric": 0,
	"dns_metric": 0,
	"delegation": true,
	"ipv4-address": [
		
	],
	"ipv6-address": [
		{
			"address": "2001:1c04:131e:6300::16",
			"mask": 128,
			"preferred": 603094,
			"valid": 603094
		},
		{
			"address": "2001:1c04:131e:6300:dea6:32ff:fefc:a753",
			"mask": 64,
			"preferred": 604254,
			"valid": 1209054
		}
	],
	"ipv6-prefix": [
		
	],
	"ipv6-prefix-assignment": [
		
	],
	"route": [
		{
			"target": "2001:1c04:131e:6300::",
			"mask": 64,
			"nexthop": "::",
			"metric": 256,
			"valid": 1209054,
			"source": "::/0"
		},
		{
			"target": "2001:1c04:131e:6300::",
			"mask": 56,
			"nexthop": "fe80::aef8:ccff:fe8f:9efa",
			"metric": 512,
			"valid": 1209054,
			"source": "2001:1c04:131e:6300:dea6:32ff:fefc:a753/64"
		},
		{
			"target": "2001:1c04:131e:6300::",
			"mask": 56,
			"nexthop": "fe80::aef8:ccff:fe8f:9efa",
			"metric": 512,
			"valid": 1209054,
			"source": "2001:1c04:131e:6300::16/128"
		},
		{
			"target": "::",
			"mask": 0,
			"nexthop": "fe80::aef8:ccff:fe8f:9efa",
			"metric": 512,
			"valid": 1797,
			"source": "2001:1c04:131e:6300:dea6:32ff:fefc:a753/64"
		},
		{
			"target": "::",
			"mask": 0,
			"nexthop": "fe80::aef8:ccff:fe8f:9efa",
			"metric": 512,
			"valid": 1797,
			"source": "2001:1c04:131e:6300::16/128"
		}
	],
	"dns-server": [
		"2001:1608:10:25::1c04:b12f",
		"2001:1608:10:25::9249:d69b"
	],
	"dns-search": [
		
	],
	"neighbors": [
		
	],
	"inactive": {
		"ipv4-address": [
			
		],
		"ipv6-address": [
			
		],
		"route": [
			
		],
		"dns-server": [
			"2001:b88:1002::10",
			"2001:b88:1202::10",
			"2001:730:3e42:1000::53"
		],
		"dns-search": [
			
		],
		"neighbors": [
			
		]
	},
	"data": {
		"passthru": "0017003020010b8810020000000000000000001020010b88120200000000000000000010200107303e4210000000000000000053"
	}
}
root@Router:~# 

tcpdump

root@Router:~# tcpdump -evni eth0.10 udp port 547 & \
> sleep 5; \
> killall -SIGUSR1 odhcp6c; \
> sleep 5; \
> killall tcpdump
tcpdump: listening on eth0.10, link-type EN10MB (Ethernet), capture size 262144 bytes
17:20:13.950233 dc:a6:32:fc:a7:53 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 187: (flowlabel 0x6e043, hlim 1, next-header UDP (17) payload length: 133) fe80::dea6:32ff:fefc:a753.546 > ff02::1:2.547: [udp sum ok] dhcp6 renew (xid=bc8722 (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96) (client-ID hwaddr type 1 dca632fca753) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0 (IA_ADDR 2001:1c04:131e:6300::16 pltime:0 vltime:0)))
17:20:13.954034 ac:f8:cc:8f:9e:fa > dc:a6:32:fc:a7:53, ethertype IPv6 (0x86dd), length 253: (flowlabel 0x3dc67, hlim 64, next-header UDP (17) payload length: 199) fe80::aef8:ccff:fe8f:9efa.547 > fe80::dea6:32ff:fefc:a753.546: [udp sum ok] dhcp6 reply (xid=bc8722 (IA_NA IAID:1 T1:302128 T2:483405 (IA_ADDR 2001:1c04:131e:6300::16 pltime:604257 vltime:604257) (status-code Success)) (server-ID hwaddr/time type 1 time 715712988 acf8cc8f9efa) (client-ID hwaddr type 1 dca632fca753) (preference 255) (DNS-server 2001:b88:1002::10 2001:b88:1202::10 2001:730:3e42:1000::53))

2 packets captured
2 packets received by filter
0 packets dropped by kernel
root@Router:~# 

/etc/config//network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdad:b459:8594::/48'

config interface 'lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option device 'br-lan'
	option ip6assign '62'

config interface 'wan'
	option proto 'dhcp'
	option peerdns '0'
	list dns '84.200.69.80'
	list dns '84.200.70.40'
	option device 'eth0.10'
	option metric '10'

config interface 'wan6'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'
	option peerdns '0'
	list dns '2001:1608:10:25::1c04:b12f'
	list dns '2001:1608:10:25::9249:d69b'
	option device 'eth0.10'

config interface 'vpnclient'
	option proto 'none'
	option device 'tun1'

config interface 'vpnserver'
	option proto 'none'
	option device 'tun0'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.20'

config interface 'ziggo_lan'
	option proto 'static'
	option device 'eth0.30'
	list ipaddr '192.168.180.1/24'
	option ip6assign '62'

config interface 'RECOVERY'
	option proto 'static'
	option device 'eth0'
	option ipaddr '10.0.10.1'
	option netmask '255.255.255.0'

config interface 'wwan'
	option proto 'dhcp'
	option metric '20'

config interface 'wg0'
	option proto 'wireguard'
	option private_key 'xxxxxxxxx'
	list addresses '10.2.0.2/32'

config wireguard_wg0
	option public_key 'xxxxxxx'
	list allowed_ips '0.0.0.0/0'
	option persistent_keepalive '25'
	option description 'WG'
	option endpoint_host '185.xxx.xxx.xxx' 
	option endpoint_port '51820'

root@Router:~# 

The DHCP6 server didn't respond with any PD. The client didn't ask any on the first hand, but since that is a dhcp renew, I suspect it didn't get it in the beginning either.

Is there anything I can try to make the client ask for a PD? Is it a setting in the config?

If I do an renew on wan6, this is in the log;

Wed Sep  7 12:22:31 2022 user.notice firewall: Reloading firewall due to ifup of wan6 (eth0.10)
Wed Sep  7 12:22:31 2022 daemon.err dnsmasq[5622]: failed to send packet: Operation not permitted

Reinstalled dnsmasq-full, didn't help

root@Router:~# opkg install --force-reinstall dnsmasq-full
Removing package dnsmasq-full from root...
Not deleting modified conffile /etc/config/dhcp.
Installing dnsmasq-full (2.85-8) to root...
Downloading https://downloads.openwrt.org/releases/21.02.3/packages/aarch64_cortex-a72/base/dnsmasq-full_2.85-8_aarch64_cortex-a72.ipk
Configuring dnsmasq-full.
udhcpc: started, v1.33.2
udhcpc: sending discover
udhcpc: no lease, failing

You already have the setting reqprefix auto. You could try to change it into a specific prefix, like /60.
dnsmasq is not related to your issue.

My isp tells me it must be on /56. Did that, didn't help.

I think my ipv6 is going bananas :wink:

Problem is that I do not really know when this happend. It worked after you helped me a while ago to set the prefix of my lan on /62. Never checked it again, I just noticed the logfile warning a few days back.

If the OpenWrt is connected on the ISP router, and the latter already has a /56, I think it won't allocate the whole /56 to OpenWrt. Most likely it will save something for other clients. So you are good with /62 or /60.
It wouldn't surprise me if they have changed something on your modem/router which broke the IPv6.

Must be the isp router/modem. I’m going to leave it for a while. I’m just interested why this is happening. And as always, thanks for the help. :wink:

1 Like

@trendy couldn't let go somehow.. I set my ISP router/modem in bridgemode (just for the test) and al works fine.

:roll_eyes:

1 Like

I am a Ziggo customer as well and I see exactly the same problem.

At least a while ago, they coudn't give a customer only IPv4 in bridge mode. Do you know whether they are now able to give a customer a public IPv4 address and IPv6 at the same time when they set a modem to bridge mode?

Hi,

When you let Ziggo put your router in bridge mode (if you’re in de former upc aerial you can do this yourself) you will get dualstack. So ipv4 and ipv6. And in bridge mode the delegation is working too.

It did work with double nat in the past at my end, don’t know why it’s not working anymore.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.