Serial Connection TL-WR841 unclean serial output

I am trying to set up TL-WR841 HW version 8.4 serial connection. However the output is somehow unclean.owrt

What errors should I look for in this case?

Already tried to desolder the pins and clean the board, but the output is still the same.

Assuming that you've got the right serial speed selected and that the logic level on your serial adapter is compatible with the router, check for appropriate pull-up/-down on the lines.

There are two empty resistor positions on the board near to RxD, might be that the issue? They were originally unpopulated...

Quite possibly. I know a pull-up is needed on my Archer C7s. Notes for that specific model at


The output is now cleaner, but I am still unable to send keystrokes to the serial port.... Maybe another resistor value is needed?

I just checked the serial adapter with my Arm board and it is working...

I had working many 841v8, it's no need any extra resistor.
Try reconfigure serial adapter setting with 57600 8N1 flow hardware off. Or try another console software e.x: minicom, putty windows.

Do you connect the VCC as well?
The baud rate is definitely 115200 as with other baud rates I am not getting any readable text.

^@ is the shell escape sequence for 0x00, for the 'y' characters I'm not sure whether it is just missing the dots (0xFF) or it's actually y (0x79).

However it still looks like are hardware issue, some more things you could try:

  • desolder the RX LED if you have one of those USB-UART converters (CP210x etc.), those bright LEDs can sometimes pull the line very high as they will use that RX line level as their only power supply...
  • check the pinout again, maybe your receiver is very sensitive and you're actually just receiving the crosstalk induced from the neighbor pin
  • just connect GND and RX at first until you have clear reception, only then add the TX line of your USB-UART, never connect 3V3

I just took a voltmeter to measure voltage between VCC and GND, it shows 0V, which is not good.

Don't connect 3.3v pin. Try measure Tx pin of router >= 2.5v, change another power supply if below.

It turned out there was a bad soldering joint on GND pin. So I desoldered the socket and soldered wires instead. Now it is working as expected. You can mark this as solved.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.