Second SSID with second interface no DHCP, packet forwarding/routing. What simple thing am I missing

Okay so here's where I'm at.

gl.inet ar750
radio1 configured as a client, that joins whatever wifi I'm around
radio0 is an access point, with a single ssid, on a br interface between ssid $ssid1 and eth1.

I would like for.

radio0 to have $N ssid's running simultaneously, each on it's own interface $int-ssid1 with a /29.

Currently, any time I create a new ssid and assign it to a new interface with a dhcp server, no dhcp is received.

tcpdump shows incoming dhcp requests on the interface but no response.

manually setting the IP/subnet/gateway on the client does not resolve the issue.

Configs are as follows
/etc/config/network (it's a /25 not a /29 at the moment)
also yes it's supposed to have it's own routing table

config interface 'int_ssid1'
	option proto 'static'
	option device 'wlan0-1'
	option ipaddr ''
	option netmask ''
	option force_link '0'
	option ip4table 'tb-ssid1'
	option gateway '$gateway'

uci show dhcp



config wifi-iface 'wifinet6'
	option device 'radio0'
	option mode 'ap'
	option ssid 'ssid1'
	option encryption 'none'
	option network 'int_ssid1'

Anybody, still struggling with this. I can do it all day every day on ubuntu or centos.

The address range on the interface only supports host IP addresses from till (126 hosts), your DHCP settings specify a start offset of 100 and a limit of 150, try lowering the start offset to 10 or the limit to 20. Also remove the option device wlan0-1 from the interface.

Upon restarting dnsmasq, check the system log for the DHCP pools being reported. Finally make sure that int_ssid1 is covered by a firewall zone or rule which allows inbound DHCP or inbound traffic in general.

1 Like

hey, yea I actually noticed that and remediated it with no change in behavior.

what's the reasoning behind removing wlan0-1 from the interface? It should be it's own interface unique from the interface associated with another SSID no?

Wireless devices must be indirectly attached to logical interfaces using option network in the wireless configuration. Referencing wifi devices from the network configuration is ignored in the best case or resulting in undefined behavior in the worst case.

1 Like

Make sure these interfaces are in a firewall zone that allows DHCP requests.

When you add a DHCP server you have to run /etc/init.d/dnsmasq restart, or reboot. A network restart won't add them to dnsmasq.

1 Like

yep that did it, now to figure out how to assign a tun0 interface to a firewall zone with this thing.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.