Second MC7455 modem not enumerating on RBM33G

Hi OWRT, Is there anybody out there running 2 modems on the RBM33G. I have 2x MC7455 LTE modems installed on this board but only one is recognised during boot. The one that's not being picked up is in the slot J10 also marked pcie1.
The firmware is ROOTer based on 18.06.2 and I have asked on their forums also but not had many responses or gained any insight yet and I feel its something to do with the hardware rather than openwrt.
I have tried with the USB jumper in place and with it removed and the pcie slot works with a pcie radio, a QCA9880 compex card.
Modem 1 in pcie0 is in MBIM mode and the second is set to QMI mode prior to installation on the board using the AT!USBCOMP command.
Can anyone help point me in the right direction please ?

Something to do with USB3 ?

Thanks for the info, I'll try it and report back, the modem was previously installed on a Turris Omnia which also required some pins taped to get it enumerated, I didn't consider the USB3 aspect of the RBM33G, hopefully I will report back with some news of success, thanks!

Taping the pins worked, thanks!!

I suppose you can disable USB3 [once you have access to the modem] instead of taping the pins.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.