Second 2.4 ghz network crashes (indicates too many clients, but only one connected)

I'm a bit new to this - I have one 5ghz and one 2.4 ghz network with the same SSID (works fine)

I'm trying to add a second 2.4 ghz network for some generic smart bulbs and switches (usual IOT thing). after getting them connected i was planning on setting up a vlan or researching better protocol for IOT things.

However, after I create the second network - as soon as I put any of the bulbs into pairing mode, the system log indicates that the STA cant be added to kernel due to too many clients (I only have one connected - it's my phone). The network seems to be stable until I try to add or remove devices from it - just my phone adds fine, I think it's something to do with how these bulbs connect.

I found a script that rebalances IRQ and installed it to run at startup but it doesnt seem to be helping. i added this script because it seems like other people were having a similar issue with the same driver and router chipset - having a 5 and 2.4 ghz network with same SSIDs then trying to add a second 2.4ghz guest network.

Here's the relevant errors from systemlog:

Sat Jun 29 20:58:00 2024 daemon.notice hostapd: phy1-ap1: STA Sat Jun 29 20:58:27 2024 kern.warn kernel: [ 1055.620945] ath11k c000000.wifi: refusing to associate station: too many connected already (512)
Sat Jun 29 20:58:27 2024 kern.warn kernel: [ 1055.620999] ath11k c000000.wifi: Failed to add station: [REDACTED  MAC ADDRSS] for VDEV: 2

here is the usual output of my router info:

{
	"kernel": "6.6.32",
	"hostname": "routey",
	"system": "ARMv8 Processor rev 4",
	"model": "Spectrum SAX1V1K",
	"board_name": "spectrum,sax1v1k",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "SNAPSHOT",
		"revision": "r26620-6b03050192",
		"target": "qualcommax/ipq807x",
		"description": "OpenWrt SNAPSHOT r26620-6b03050192"
	}
}

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd0e:ca41:83::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'


config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc@0/c000000.wifi'
	option channel '36'
	option band '5g'
	option htmode 'HE80'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'ssid_0'
	option encryption 'psk2'
	option key 'password_redacted'
	option disassoc_low_ack '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc@0/c000000.wifi+1'
	option channel '4'
	option band '2g'
	option cell_density '0'
	option country 'US'
	option htmode 'HE20'
	option legacy_rates '1'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option ssid 'ssid_0'
	option encryption 'psk2'
	option key 'password_redacted'
	option network 'lan'
	option disassoc_low_ack '0'

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'ap'
	option ssid 'ssid_1'
	option encryption 'psk2'
	option key 'password_redacted'
	option network 'lan'
	option wmm '0'
	option skip_inactivity_poll '1'
	option disassoc_low_ack '0'


config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option ednspacket_max '1232'
	option confdir '/tmp/dnsmasq.d'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config host
	option name 'octopi'
	option ip '192.168.1.20'
	list mac 'MAC_redacted'
	option leasetime 'infinite'

config host
	option name 'choadling'
	list mac 'MAC_redacted'
	option ip '192.168.1.10'
	option leasetime 'infinite'

config defaults
	option syn_flood	1
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	MAC_redacted
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	MAC_redacted
#	option src_port	80
#	option dest		wan
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	MAC_redacted
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp

here is the results of /cat/proc/interrupts

root@routey:~# cat /proc/interrupts
           CPU0       CPU1       CPU2       CPU3
  9:          0          0          0          0 GIC-0  39 Level     arch_mem_timer
 13:      39412      63505      43777      37228 GIC-0  20 Level     arch_timer
 16:          0          0          0          0 GIC-0 239 Level     bam_dma
 17:          0          0          0          0 GIC-0 270 Level     bam_dma
 18:          0          0          0          0 GIC-0 178 Level     bam_dma
 19:          7          0          0          0 GIC-0 354 Edge      smp2p
 20:          6          0          0          0 GIC-0 340 Level     msm_serial0
 22:          0          0          0          0 GIC-0 216 Level     4a9000.thermal-sensor
 23:          0          0          0          0 GIC-0  35 Edge      wdt_bark
 24:       3183          0          0          0 GIC-0 155 Level     mmc0
 25:          2          0          0          0 GIC-0 170 Level     7824900.mmc
 26:          0          0          0          0 GIC-0 357 Edge      q6v5 wdog
 27:          0          0          0          0  pmic_arb 51380237 Edge      pm-adc5
 28:         12          0          0          0 GIC-0  47 Edge      cpr3
 29:          1          0          0          0     smp2p   0 Edge      q6v5 fatal
 30:          3          0          0          0     smp2p   1 Edge      q6v5 ready
 31:          0          0          0          0     smp2p   2 Edge      q6v5 handover
 32:          0          0          0          0     smp2p   3 Edge      q6v5 stop
 33:          0          0          0      78062 GIC-0 377 Level     edma_txcmpl
 34:          0          0          0          0   msmgpio  34 Edge      keys
 35:          0          0          0          0 GIC-0 385 Level     edma_rxfill
 36:          0          0          0      81319 GIC-0 393 Level     edma_rxdesc
 37:          0          0          0          0 GIC-0 376 Level     edma_misc
 38:        191          0          0          0 GIC-0 353 Edge      glink-smem
 39:         10          0          0          0 GIC-0 348 Edge      ce0
 40:     109410          0          0          0 GIC-0 347 Edge      ce1
 41:     135197          0          0          0 GIC-0 346 Edge      ce2
 42:       3639          0          0          0 GIC-0 343 Edge      ce3
 43:          0          0          0          0 GIC-0 443 Edge      ce5
 44:       8788          0          0          0 GIC-0  72 Edge      ce7
 45:          0          0          0          0 GIC-0 334 Edge      ce9
 46:          0          0          0          0 GIC-0 333 Edge      ce10
 47:          0          0          0          0 GIC-0  69 Edge      ce11
 48:          0      18418          0          0 GIC-0 189 Edge      wbm2host-tx-completions-ring1
 49:          0          0          0          0 GIC-0 323 Edge      reo2ost-exception
 50:        485          0          0          0 GIC-0 322 Edge      wbm2host-rx-release
 51:          0          0          0          0 GIC-0 209 Edge      rxdma2host-destination-ring-mac1
 52:          0          0          0          0 GIC-0 212 Edge      host2rxdma-host-buf-ring-mac1
 53:          0          0       3747          0 GIC-0 190 Edge      wbm2host-tx-completions-ring2
 54:          0          0          0          0 GIC-0 211 Edge      rxdma2host-destination-ring-mac3
 55:          3          0          0          0 GIC-0 235 Edge      host2rxdma-host-buf-ring-mac3
 56:          0          0          0        258 GIC-0 191 Edge      wbm2host-tx-completions-ring3
 57:          0          0          0          0 GIC-0 210 Edge      rxdma2host-destination-ring-mac2
 58:          0          0          0          0 GIC-0 215 Edge      host2rxdma-host-buf-ring-mac2
 59:        220          0          0          0 GIC-0 321 Edge      reo2host-status
 60:          0     160925          0          0 GIC-0 261 Edge      ppdu-end-interrupts-mac1
 61:          2          0          0          0 GIC-0 255 Edge      rxdma2host-monitor-status-ring-mac1
 62:          1          0          0      22789 GIC-0 263 Edge      ppdu-end-interrupts-mac3
 63:          0          0          0          0   msmgpio  63 Edge      keys
 64:          2          0          0          0 GIC-0 260 Edge      rxdma2host-monitor-status-ring-mac3
 65:          0          0          0          0 GIC-0 262 Edge      ppdu-end-interrupts-mac2
 66:          0          0          0          0 GIC-0 256 Edge      rxdma2host-monitor-status-ring-mac2
 67:       1636          0          0          0 GIC-0 267 Edge      reo2host-destination-ring1
 68:          0       2050          0          0 GIC-0 268 Edge      reo2host-destination-ring2
 69:          0          0       1647          0 GIC-0 271 Edge      reo2host-destination-ring3
 70:          0          0          0      14330 GIC-0 320 Edge      reo2host-destination-ring4
IPI0:      1884       1746       2005       2107       Rescheduling interrupts
IPI1:     90272     119577      85618      54089       Function call interrupts
IPI2:         0          0          0          0       CPU stop interrupts
IPI3:         0          0          0          0       CPU stop (for crash dump) interrupts
IPI4:         0          0          0          0       Timer broadcast interrupts
IPI5:       540        510        532        438       IRQ work interrupts
IPI6:         0          0          0          0       CPU wake-up interrupts