Seafile-server package on x86 target does not work

Good morning, hello, everybody.

I've been using OpenWrt on my home routers and friends for a while. I think it is a great example of what a group of people with vision and effort can achieve. I have tried to successfully test many of the features and also additional packages. It's what I like about this software, it gives us the freedom to choose from many feature options depending on our needs being managed by our local data networks.One of the features that excites me is being able to have our own cloud to store our daily work on the computer. For this reason I have tried, without success, to install and test the SEAFILE SERVER software.

Base hardware: Virtualbox VM, 1GB RAM, 20GB VHD, eth0: host-only as LAN, eth1: Bridge mode as WAN

Openwrt version: 19.07.6-x86-generic-combined-ext4.img

Installed package with: opkg update && opkg install seafile-server

Below are the problems that have been presented to me:

1.Missing packages reported by the installer. Fixed with:

opkg update && opkg install python-django-statici18n python-django-webpack-loader seafile-server

2.Database creation failed. Fixed with:

cd /usr/share/seafile

sqlite3 seahub.db

CREATE TABLE IF NOT EXISTS 'django_content_type' (
'id' integer NOT NULL PRIMARY KEY AUTOINCREMENT,
'app_label' varchar(100) NOT NULL,
'model' varchar(100) NOT NULL
);

CREATE TABLE IF NOT EXISTS "auth_permission" (
"id" integer NOT NULL PRIMARY KEY AUTOINCREMENT,
"content_type_id" integer NOT NULL REFERENCES
"django_content_type" ("id"),
"codename" varchar(100) NOT NULL,
"name" varchar(255) NOT NULL
);

.quit

When running "/etc/init.d/seafile setup" without errors, I configured the following data for Seafile:

server name: seafile

ip: 192.168.56.2

Port ccnet server: 10001

Seafile data directory: /usr/share/seafile/seafile-data

Port seafile server: 12001

Port seafile fileserver: 8082

To finish, start Seafile with:

/etc/init.d/seafile start
/etc/init.d/seahub start

The program responds: this is the first time you start Seafile, we will create the admin user:

Administrator e-mail: **@**
Password: **

I get here after several weeks of internet research, I go to my PC, I open Mozzilla Firefox and place 192.168.56.2:8000

Result:

Page unavailable

Sorry, but the requested page is unavailable due to a server hiccup.
Our engineers have been notified, so check back later.

If any of you have the solution that wants to share it, it would be great.

Thank you.

I have simillar problem, check logs for seahub. I need to create also

CREATE TABLE IF NOT EXISTS `django_session` (
  `session_key` varchar(40) NOT NULL,
  `session_data` longtext NOT NULL,
  `expire_date` datetime NOT NULL,
  `created` datetime NOT NULL,
  `last_login` datetime NOT NULL
); 

when I have created this table this error gone but now via browser url is loading and loading ;/

Thanks for answering.
I'm testing it right now.

Sorry buddy, but it doesn't work. After invoking the Seafile's website, it stays loading indefinitely.

In Openwrt's database of additional functionalities, there should be no packages that do not work.

It is a loss of credibility and seriousness for the brand. Responsible administrators should not allow it.

Thanks

The position as every package tester on every platform, in every release in open, feel free to apply.

I got exactly the same problem than you, wow incredible that we finish on the same thing !
Still zero update ? Because I really want an online file manager for my NAS.

Well I found this on my side : https://forum.seafile.com/t/web-server-not-working/4539/2
After installing it and being on this webpage the next step is to stop the two services
/etc/init.d/seafile stop /etc/init.d/seahub stop
Next is to delete the temp folder : rm /tmp/seahub_cache/ -r
Restart the two services :
/etc/init.d/seafile start /etc/init.d/seahub start
It will ask you a email and a password for the admin.
And now you are... Still on this webpage but hey now you're at the address http://192.168.x.x:8000/accounts/login/
I Guess that count.

Well the Seafile client software seems to be able to use Seafile onto my NAS but damn I really want this web interfaces ! Maybe our device are too slow to show the webpage itself but syncing file still work.