Screwed Up Network Config file

I screwed up.. Using a RPi4b installing and setting up Openwrt for the first time I was attempting to create 2 vlans in the process I unconfigured the lan bridge in luci > network > interfaces > devices. This left me with a non functional Openwrt. In my desperation to not start from scratch I pulled the SD card and edited the /etc/config/network to replace the bridge section from the best memory I had.

This has got Openwrt up and running again (sort of :sob:) but when clicking on luci > network > interfaces I'm faced with this error..

RPCError
RPC call to uci/get failed with ubus code 9: Unspecified error
at handleCallReply (http://192.168.3.1/luci-static/resources/rpc.js?v=git-24.086.45142-09d5a38:15:3)

Is it possible to identify a solution to my problem please...

/etc/config/network 

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
config globals 'globals'
        option ula_prefix 'fdc6:c431:44dd::/48'
config device option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
config interface 'lan'
        option device 'eth0'
        option proto 'static'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'
config interface 'wan'
        option proto 'dhcp'
        option device 'eth1'
        option hostname '*'
        option peerdns '0'
        list dns '192.168.3.1'
config interface 'vlan4'
        option proto 'static'
        option device 'myIOTBridge'
        option ipaddr '192.168.4.1'
        option netmask '255.255.255.0'
config device
        option type '8021q'
        option ifname 'eth0'
        option vid '3'
        option name 'eth0.3'

Ok got it... This idiot didn't format the file correctly, sorry for my foolishness

Change the device to br-lan in the lan interface:

You don't have a device called MyIOTBridge so that's going to fail...

I'd recommend this:

config interface 'vlan4'
        option proto 'static'
        option device 'eth0.4'
        option ipaddr '192.168.4.1'
        option netmask '255.255.255.0'

delete this:

Also, it's not recommended to self-reference the DNS server... remove the last 2 lines... if you want to use a public or other upstream DNS, that's fine, but for now just delete them and use the DHCP issued DNS server.

Then reboot and try again.

1 Like

Thank you... All great again. I only self referenced the DNS as I have an instance of Adguard Home on the same Pi thinking I need too.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.