Screen resolution when running x86 in Virtualbox

I'm working with the x86-64 target build of OpenWrt and running it in VirtualBox. When it boots, the screen resolution is 640x480. Is there a way to change this?

It's easier to connect with SSH from the host.

1 Like

I don't have network connectivity yet. Is there a way to modify the screen resolution?

What video drivers have you installed?

(BTW, I tried to see if there was a way to do so in Grub, no success as of yet.)

I am running the x86 VM build of OpenWrt 18.06 inside VirtualBox. I am just using the default. I thought there was a command line option you pass to the Kernel to adjust the resolution. I haven't been able to find a way to configure this version of Grub either.

I did, but doesn't work: https://wiki.archlinux.org/index.php/GRUB/Tips_and_tricks#Setting_the_framebuffer_resolution

Ok, I got it to change the resolution by adding "vga=795" to the kernel command line by manually editing /boot/grub/grub.cfg with vi and rebooting. Now, how can this be added as a build time setting so it is permanent?

For reference: http://pierre.baudu.in/other/grub.vga.modes.html

3 Likes

Ahhha! I forgot the CFG file is on another partition!

Glad you got it working.

Yes. There's quite a few thread about adding custom build parameters.

SOLVED:

So, to make this permanent, if you go into menuconfig under "Target Images" you can add "Extra kernel boot options". Just add "vga=795" to this, save and rebuild.

3 Likes