Screen Resolution Control With OpenWRT on PC?

Screen Resolution Control With OpenWRT on PC? Have PC running OpenWRT, connected to HDMI monitor and have a common problem with HDMI monitors, the video card is over scanning, i.e. screen image is bigger than monitor display view, not a resolution issue but an over scan issue. How do I enable over scan control so I can address this issue?

try in grub.conf

No, does not work. I can change the resolution to whatever I want. The issue is not setting the resolution. That is working. The issue is how to enable overscan, so that I can force the monitor to shrink the image at the given resolution. It is a common issue with HDMI monitors that under or over scan the image, thus going of the edge of the viewable space, or not expanding to the viewable space of the monitor for the given resolution. The overscan in my case happens at any resolution I set.

Moreover there not way to re-generate the grub configuration on PC version of OpenWRT? And the configuration file is in a different location than the web page example.

Vi is a good regenerator.

You probably didn't notice, but the link had zero relation to openwrt, but they did have something in common, grub and the Linux kernel.

If your monitor overscans, solve it in plain Linux 1st, then apply the solution to your openwrt.

You might want to try using VGA instead, if that's a connector you've got.

Overscan is usually 100% an issue with your screen configuration, solved by disabling that mis-feature using its OSD menus. It shouldn't occur on PC monitors at all, but sadly is prevalent on TV screens abused as PC monitor.

What you say is true, HOWEVER, every system I have works fine with this REAL HDMI monitor, not a TV. Same hardware running core Debian 9, 10, 11, etc. NO ISSUES. The only OS/drivers having an issue IS OpenWRT. Hence why I posted the question. Even my Raspberry Pi device, which have a LONG history with overscan issues, works fine with this HDMI monitor.

I was also confused when I needed to change the cmdline, because grub on OpenWRT can be edited and it does not need update-grub2. Just editing the file /etc/grub/grub.cfg and then restarting did apply changes permanently. I confirmed this by looking at cat /proc/cmdline after reboot.

Perhaps that is the missing piece of information here (=just skip sudo update-grub2 from the guide frollic posted)?

Check if your tv has a setting for PC mode oi r game mode

Applies to regular grub too, it's just a convenience script ,)

1 Like

NOT A TV. It is a Dell 27in IPS monitor. The odd thing is, it is ONLY OpenWRT now that is exhibiting the overscan. I have connected many devices to this same monitor. The only other device that had an issue is a Raspberry Pi. Pi devices are noted with having issues with over scanning even on standard monitors, so they have a strong overscan control methodology. The newer Pi devices latest 3B and 4B don't have the same issues the older Pi devices, I swapped a Pi 4 device using CEA mode 16, which 1920x1080, which is the default native resolution for this monitor, it was rock solid correct.

In the long run this is not a major issue since 90% of the time you use the web interface to manage and control configuration. But this is a quirk that is... an itch that is turning out to be hard to scratch. Usually when overscan is an issue the frequency variance can be an issue, but this specific monitor is a straight 59.9, i.e. 60 hertz device. The one thing I have not tried, is swapping out the HDMI cable, which I will try next.