Samsung CY-SWR1100 radios are not working even after enabled, please help

The builds that are available don't seem to support the device and the onboard radios dont work after being enabled.

Please help to fix

The device is supported...

https://openwrt.org/toh/views/toh_fwdownload?dataflt[Brand*~]=samsung&dataflt[Model*~]=CY-SWR1100

SSH in to the router and run the following...

cat /etc/config/wireless

Note: Make sure to obscure the "option key" value(s) in the wireless config results before posting.

Hello, this is my wireless config:

cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:01.0/0000:01:00.0'
        option country 'GB'
        option htmode 'HT40'
        option channel '1'
        option txpower '20'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option key 'wifi_key'
        option mode 'ap'
        option wpa_disable_eapol_key_retries '1'
        option encryption 'psk2+ccmp'
        option ssid 'nxs0_ap'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11a'
        option path 'platform/10180000.wmac'
        option country 'GB'
        option channel '46'
        option htmode 'HT40'
        option txpower '20'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key 'wifi_key'
        option wpa_disable_eapol_key_retries '1'
        option ssid 'nxs0_trunk'
        option encryption 'psk2+ccmp'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/101c0000.ehci/usb1/1-1/1-1:1.0'
        option country 'GB'
        option htmode 'HT40'
        option txpower '20'
        option hwmode '11g'
        option channel 'auto'

config wifi-iface
        option device 'radio2'
        option mode 'ap'
        option ssid 'wifi_key'
        option network 'lan'
        option key wifi_key'
        option encryption 'psk2+ccmp'
        option wpa_disable_eapol_key_retries '1'

lede_wifi

radio2 is usb wifi dongle with Ralink RT5572 chipset.

1 Like

@jwoods
I have the same issue with all the builds I tried the devices radios dont seem to be available after enabling them?

Yes the same problem, tried older builds, but it didn't work. I was using DD-WRT before without any problems (SWR1100_3.4.3.9-096_base).

So I've tried again 17.01.5 and 18.06.0-rc2, but no luck, radios are not working.

1 Like