Same interface - AP & Client 5GHz


The 5GHz interface of my MiWiFi 3G router is configured as AP and Client.
It has been working for a year, but this week I've got a weird issue I cannot resolve..

The client had to change its channel to 112 (5.560 GHz), since the remote AP went to this frequency.
Ever since, my AP is no longer working ..
And I get the following error message in the logs: kernel: [ 2508.072906] device wlan1-0 entered promiscuous mode
daemon.notice hostapd: wlan1-0: interface state UNINITIALIZED->COUNTRY_UPDATE
daemon.notice hostapd: wlan1-0: interface state COUNTRY_UPDATE->DFS
daemon.notice hostapd: wlan1-0: DFS-CAC-START freq=5560 chan=112 sec_chan=0, width=0, seg0=0, seg1=0, cac_time=60s
daemon.notice wlan1-0: DFS-CAC-COMPLETED success=1 freq=5560 ht_enabled=0 chan_offset=0 chan_width=3 cf1=5560 cf2=0
daemon.err hostapd: Using interface wlan1-0 with hwaddr **:**:**:**:**:** and ssid "*********"

daemon.notice hostapd: wlan1-0: interface state DFS->ENABLED
daemon.notice hostapd: wlan1-0: AP-ENABLED
daemon.notice hostapd: wlan1-0: DFS-PRE-CAC-EXPIRED freq=5560 ht_enabled=0 chan_offset=0 chan_width=0 cf1=5560 cf2=0
daemon.notice hostapd: handle_probe_req: send failed                                                                                          
daemon.err hostapd: Failed to set beacon parameters
daemon.err hostapd: Failed to set beacon parameters

I tried with htmode = VHT20 / VHT40 / VHT80 / NOHT
But didn't help.

Here is my configuration :

config wifi-device
    option type 'mac80211'
    option hwmode '11a'
    option path '****'
    option channel '112'
    option country 'CA'
    option htmode 'VHT20'

config wifi-iface
    option ifname 'wlan1-0'
    option device 'radio1'
    option network '****'
    option mode 'ap'
    option ssid '****'
    option key '****'
    option encryption 'sae'

config wifi-iface
    option ifname 'wwan1'
    option device 'radio1'
    option network '****'
    option mode 'sta'
    option key '****'
    option disassoc_low_ack '0'
    option encryption 'psk2+ccmp'
    option bssid '**:**:**:**:**:**'

OpenWRT version :

DISTRIB_DESCRIPTION='OpenWrt 19.07.7 r11306-c4a6851c72'

Architecture :

│  Internet   │
│             │
│   Router X  │
    │ AP 1 │
│AP 2 │  Client │
│     │         │
│  MiWifi 3G    │
│  OpenWRT      │

If someone get an idea that may help, that would be nice :slight_smile:
Thank you in advance !

112 is a DFS channel, and most drivers don't support simultaneous AP and client on DFS channels. The client will work, but the AP will throw "failed to set beacon parameters" errors and refuse to start.

There's really nothing you can do from your end other than add hardware to use separate radios.

1 Like

Oh .. interesting, thank you for the answer !
.. well I suppose if a jam all DFS channels the remote router should go back to a non DFS channel :thinking:

More seriously, before, it was on channel 60 (5.300 GHz)
For what I see in the wiki, in Canada that is still a DFS channel, isn't it ? (

Other than the fact that's illegal...and may have your military, radio enforcement or civil aviation authorities come looking for you.

Is there a reason you don't use a non-DFS channel?

The other solution is to set the upstream AP so it doesn't do that.

Sorry for the confusion, I thought it was clear that it was not a seriously considered solution (aka joke)

I don't administrate the remote router, I suppose it moves to channel 112 because 60 became too busy.
Though, as they seems to be both DFS, i don't quite understand why my configuration stopped working suddenly.

I got the joke...others may not have (and in some places it's not explicitly illegal in civil law; but the military will show you how much they care about you doing so! :wink: ).

Maybe change the MAC...but this means they may have blocked you...

Well...the problem is, if you want to setup downstream AP (backhaul), it's usually good practice to set the upstream channel so it doesn't move.