Samba4 - removing unnecessary contained packages

Since upgrading to 21.02.1, I only have 1.1MB of free space available, where I had 12.8MB prior the upgrade.

I've the Samba4 package installed and am looking at removing any unnecessary packages that were installed with this package.

My use case is:

  • shared USB flash drive folders, mounted on OpenWrt router (formatted as f2fs)
  • access the shared folders using Windows v8.1, v10 or v11 clients

I believe these are all the packages Samba4 installs:


I'm clueless as to the bare minimum packages required to have Samba4 functioning for my uses case.

Grateful for any pointers!

Replace it with ksmbd instead.

1 Like

Yes, tried using ksmbd last night & using Windows 8.1 & 10, however it's not playing nicely.

i.e. can access the shared directory, create a new file & edit it, however if I try to delete the file, it either:

  • hangs the Windows explorer process until it restarts, this is reoccurring, still not deleting the file
  • at other times when pressing delete nothing occurs
  • rebooted the router & Windows clients, same

Samba4 just works, likewise its predecessor Samba36

Sounds like a permission issue to me...

Maybe helpful: When switching between samba and ksmbd, or when updating an smb server, it is sensible to clear Windows' Kerberos ticket cache. Keeping the Kerberos tickets but changing the server they relate to can lead to strange side effects.

Open an command prompt as administrator and issue
klist purge

What you have is the current "minimal" samba4 server installation and outside from switching to ksmbd or using a extroot there is nothing else you can do.
The main issue is that starting with samba4 the build system was changed and all the old 3.6 hacks to trim down the server size do not work anymore.


I'm not too sure, Windows generally throws an error/permission error if something isn't right.

Thanks for the suggestion, will remove Samba4 then reinstall ksmbd in the next few days & try the klist purge, just strapped for time ATM.

Actually this post Can the avahi-daemon service be disabled? spurred me into thinking there's a possibility that some packages of the Samba4 could get uninstalled.

Thanks for the info though.

Sure on a windows only setup you can remove Avahi daemon/bins, but you still need the avahi-lib since samba is compiled against it. The bulk size is in the samba-lib package anyway, which cant be reduced.

Well it seems that any other Windows user profile I use (not being my current profile) within Windows 8.1 / 10, works with ksmbd.

I tried removing any current remote connections of my current profile by using the commands:
net use * /d ....then followed by.... klist purge ....however it's not making any difference.

EDIT: the only way I got ksmbd to work using my current Windows profile, was to change the share-name

I gather the old Samba4 share-name that I previously used, is somehow still utilized within Windows and clashes with the ksmbd installation?

Nevertheless, early days using ksmbd, happy that I have now reclaimed 12MB of free package space!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.