Samba USB drive size not match

I followed the instructions on how to install & setup Samba with USB device, my 32GB USB flash drive was detected (32GB) in OpenWRT and showed up on my local network with Read/Write access.

The only problem is that I only see the drive in 60MB capacity on network, the USB flash drive is 32GB. Where did I miss?

Forgot to mention that the 32GB USB flash drive was pre-formatted in FAT32 before setup Samba.

Thanks in advance for advice.

The drive is not mounted properlu, or you are sharing a different folder, not where the drive is mounted. You are not sharing the external drive, but the router's internal memory.

We need more.details...

1 Like

Thanks for the fast response, please see the smb.conf if there is anything wrong with it. I can attach a screenshot from OpenWRT router settings page if it will help.

[global]
netbios name = OpenWrt
display charset = UTF-8
interfaces = lo br-lan
server string = OpenWrt_NetShare
unix charset = UTF-8
workgroup = WORKGROUP
bind interfaces only = yes
deadtime = 30
enable core files = no
invalid users = root
local master = no
map to guest = Bad User
max protocol = SMB2
min receivefile size = 16384
null passwords = yes
passdb backend = smbpasswd
security = user
smb passwd file = /etc/samba/smbpasswd
use sendfile = yes

[OpenWRT_USB]
path = /mnt/sda1
read only = no
guest ok = yes
browseable = yes



You mount point (mnt/sda1) doesn't appear to be mounted, try clicking Mount Attached Devices (the button at the top of your screenshot - Luci > System > Mount Points).

When it’s mounted you should see it listed in Mounted File Systems

1 Like

Tried "Mount Attached Devices" before, it didn't work.

I found the cuprit, the USB drive was formated as "0700 - Microsoft basic data" (fat32) partition automatically by Windows 10. :laughing: gdisk says MBR/GTP table is invalid...

I reformat it using f2fs system, now working properly in openWRT.

Thank you guys for the time try to help, problem solved and please close this thread.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.